API subdomain not working with "Proxied"

Details
We wanted to turn on the “Proxied” status for our API subdomain. However, turning it on will make the API unavailable/inaccessible.

What We Did (but didn’t work)

  1. Added “API” subdomain with A record pointing to the IP of our API.
  2. Turn on the Proxy
  3. Used Origin Certificate (we test certs of both domains below)
  1. Uploaded the certificate to API server
  2. Change the “Flexible” to “Full Strict”

What could be the issue?

What is the error you get when trying this domain? Chances are there’s either a browser error or CF error [which would be found in the response body of a HTTP request].

The error is if the API is not proxied. it will be rendered with “HTTP” and if we turn it on it will be rendered “HTTPS” BUT the API will fail.

The error when it’s in HTTPS mode is important; if SSL mode is flexible, it will connect to your API via port 80, Full/Full Strict will connect via port 443/TLS.

I see! Will send this to my dev for checking. Will get back here once solved and tick that solution checkbox. Thanks Judge!