API Request from Klaviyo not going through

I’m trying to connect Klaviyo to my website but I keep getting an API error “Unable to access: https://darshanabeauty.com/wp-json/wc/v3/. 403 authorization error”. I can see in the Cloudflare firewall log that it is a “Managed Challenge”.

I have tried using the URL in the error in a page rule to allow it through but I haven’t had any success. I also have a firewall rule to bypass all WAF for the user agent Klaviyo. It’s still not connecting.

Any ideas? (Please be as specific as possible with your advice or firewall/page rules since I’m still learning all this)

Thank you!
Darius

If you click on that entry, you should see which “Managed Challenge” stopped it. In my case, I have Bot Fight Mode for Definite Bots (paid plan).

Yes, that’s the exact rule! How did you allow it through? I’ve already used a firewall rule to “bypass” the WAF for their user agent “Klaviyo/1.0”

I turned off the “Super Bot Fight Mode” by allowing Definitely Automated and Verified Bots from the article here Frequently asked questions about Cloudflare bot products – Cloudflare Help Center

If anyone knows of a more secure way of doing this please let me know.

Thanks!

Yeah, I’ve had to do that too. For now, there’s no way to make exceptions to that feature.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.