API Request Failed: POST /intel/attack-surface-report/checkers/spf_check (503)

Hi,

Just now, I’m seeing this issue after logging into my Cloudflare dashboard:
API Request Failed: POST /api/v4/accounts/{redacted}/intel/attack-surface-report/checkers/spf_check (503)

I don’t understand why this happening. Please suggest some way to get over this.

Thanks a bundle

4 Likes

I see exactly the same error since this morning.

1 Like

Have the same problem

I got the same error message to.

What’s going on?

I am experiencing the same issue. It only occurs for one of my domains, not all of them. I can reproduce this by going to the DNS page and every time I reload the DNS page in the dashboard.

I fixed this issue by deleting a TXT record I had pertaining to protonmail.

Yeah Same issue since morning

only shows up in the DNS section of one of my websites.

Same here. Kind of annoying not knowing where it comes from …hm.

do you have a TXT record that is for protonmail?

If you open the developer console and go on the network tab before reloading the DNS page, there should be a red line corresponding to the error in question, then click on that and on the ub-tab called “request”.

That’s where i saw which record was causing the problem. In my case this was the TXT record I mentioned.

Same, for me. The problem with SPF records with any Email senders, not only protonmail. Hope it will be fixed ASAP :smiley:

I have the same problem. :cactus:

1 Like

Thanks for your response @user16471. I have checked the Developer Console.
This is what I got:

Still no clues on what to fix :man_shrugging:

I’m facing the same Error

1 Like

Same error on DNS config page, got no TXT records

Could you try to open the developer console as described above to see what record(s) cause(s) the issue?

You’re welcome. In my case I removed the record because I don’t think it is used. I can always recreate it later if needed.

I have the same issue

2 Likes

Hi,

Just now, I’m seeing this issue after logging into my Cloudflare dashboard:
API Request Failed: POST /api/v4/accounts/{redacted}/intel/attack-surface-report/checkers/spf_check (503)

I use privateemail dns

this causes the problem, how can i fix it?
v=spf1 include:spf.privateemail.com ~all

Thanks a bundle

1 Like

I’ve escalated this issue to Cloudflare Support, however it does not seem to prevent you from managing DNS records if you ignore the message.

2 Likes

Same here… about 2 years spf records worked perfect, but now, 4 days in a row, I’m getting the same error.
Anyone found a solution?

1 Like

I don’t think there is actually anything wromg with the SPF and DNS records still seem to be working fine.

1 Like