API calls stuck at initial connection

Hi Cloudflare Community,

I have a network issue and I’m reaching out to see if anyone has experience with my current situation.

Case Scenario
I’m currently using Cloudflare to manage my client’s DNS and I have a sub-domain for backend and I’m using the root for my frontend. Every once in awhile I get stuck at the “initial connection” state as the image shown below until the api call is disconnected resulting in the api isn’t being called.

When the traffic for the root domain is higher than usual(around 15k requests), I’m completely unable to get pass this stage for the sub-domain at all.

Diagnosis

  • Tried purging cache every once in awhile and it works sometimes but now it’s getting worst and even purging cache doesn’t solve the issue.
  • Tried adjusting the browser cache TTL, if I set it higher (>4hrs) it gets worst, and if I set it to (<1hrs) it happens less often.
  • Enabled Cloudflare’s Tiered Cache Topology.
  • Tried setting WAF IP access rules to allowlist client’s IP and country.

Help needed

  1. Any idea why does Cloudflare takes some time to establish the connection(The browser is establishing a connection, including TCP handshakes or retries and negotiating an SSL.)?
  2. Is 15k requests and 26mb bandwidth an hour considered a lot?
  3. What can I do(what do I need to check/upgrade) to solve this?

All the above diagnostic steps taken did help but did not solve the issue completely. I apologize due to P&C I’m unable to disclose the exact IP address and domain name.

Any help or suggestion provided from the community or Cloudflare experts would be appreciated, and thank you in advance for your time! :wave:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.