API 403 after enabling Cloudflare

Hi,
I have configured my website to use Cloudflare yesterday. I don’t have any firewall rules etc., so using the standard basic setup od Cloudflare.
My REST API is not working now. I am getting 403 result code. When I try to access it via a second address (not configured in Cloudflare) everything is fine, so the problem is related to Cloudflare.
I am using HTTPS.
I tried various page rules, disabling security and all on the /webapi/rest/* url path but with no luck.
Do you have any advice? Is this Cliudflare related or is this something on my website provider side?

Thanks!
Peter

You might be running into a Cloudflare challenge. You could either lower the security level or whitelist the IP address.

1 Like

Thanks. Will try this in the evening. I got a similar response from my shop provider, they gave me the IP address to whitelist.

Can you check which response body you receive? Have you checked your Cloudflare firewall event log?

Whitelisting IP did not work.
This is the response I get:

Please enable cookies. Error 1010 Ray ID: … . Access denied. The owner of this website (my website listed here) has banned your access based on your browser’s signature.


Yes, it says “no firewall events”.

Post screenshots of these three pages

https://dash.cloudflare.com/redirect?zone=firewall/firewall-rules
https://dash.cloudflare.com/redirect?zone=firewall/tools
https://dash.cloudflare.com/redirect?zone=firewall/settings



You could try disabling the “Browser Integrity Check”. Also, is your request being sent from China?

1 Like

No, my request is not being sent from China. This is to withhold DDoS attacks I had recently. Browser integrity check won’t weaken my website security?

Browser integrity check has fixed the issue though.

This topic was automatically closed after 14 days. New replies are no longer allowed.