Anybody help me? if i open http URL it is still opening on the website not redirecting to HTTPS


#1

Can anybody assist me and can share the code that what i should add in the .htaccess OR do something else with cloudflare dashboard to redirect http pages to https.

Note: I am already applied forwarding rule http://www.example.com/* 301 redirection https://www.example.com/$1 but it didnt work in my case.


#2

To do the HTTPS redirect there is a toggle in the Crypto settings (“Always Use HTTPS”), remove the page rule. Other issues are hard to diagnose without knowing the domain name, but usually people have the domain set to :grey:.


#3

HI matteo,

i have removed the page rule, what is happening at the moment.

If i open my website it okay redirect auto on https.

But when i open internal pages they also first open on https URL but if remove “S” from the internal pages so they don’t redirect again on https this is the problem i am facing hope you understand.


#4

Well, it seems really strange to me as it doesn’t happen (all HTTP requests passing through Cloudflare will get redirected to HTTPS, do you have an URL I can try and test?


#5

check out this one

if you remove “S” from https so it doesn’t not reopen on https URL.


#6

Any Luck???


#7

The issue here is that the root domain (and the www subdomain) are not actually under Cloudflare.

No features of Cloudflare (except the actual DNS resolution) work if the hostname is :grey:. Go to the DNS settings and set them to :orange:. The issue was the same as mentioned in the first post.

The Always Use HTTPS rule (as did the Page Rules before) require the proxy to be active.


#8

Thanks… :slight_smile: It’s working now perfect.


closed #9