Angular app deployed to Pages is unavailable on domain

I’ve deployed an angular app to Pages from a github repo but the domain is always unavailable. I tried it last week but I can’t get it to load on the domain.

The pages link is https://linkfully-app.pages.dev/

Welcome to the Cloudflare Community!

It’s not unavailable, it’s just 404ing. There is a deployment there, just not build the way you think it is/under a subdirectory.

If you navigate to your Pages Project, the default Deployments tab, and click “View Details”, under “Assets Uploaded” what files do you see?
Magic Link: https://dash.cloudflare.com/?to=/:account/pages/view/:pages-project/:pages-deployment/files

In your Pages Project, under Settings → Builds & Deployments → Build Configuration, what’s your build command / output directory / root directory?

For Reference, here’s Pages deploy guide here: Deploy an Angular site · Cloudflare Pages docs

Thanks for your response.

Assets uploaded:

I assume I would change the output to dist/browser? Does the “3rdpartylicenses.txt” matter at all if it is excluded?

Build Config:

Okay, I changed the output to dist/browser and it works now. Just not sure about the 3rdpartylicenses.txt

3rdpartylicenses.txt is a angular thing:

could stick it in an about page or something:

Regardless, you figured out the build issue indeed.

I’ve just created a post-build script to move the text file to the browser folder so now it’s fine.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.