Android Pie "Could not connect" system wide in settings

bug

#1

Tried connecting to 1dot1dot1dot1.cloudflare-dns.com but Android settings returned “Could not connect”. OpenVPN seems to interfere with 1.1.1.1. Any ideas on a workaround?


#2


“Private DNS”
“Could not connect”


#3

It’s probably your OpenVPN config. It’s the same for me. I am routing all my traffic through the tunnel and my server pushes two internal DNS servers (pi-hole) which are configured to send encrypted requests to Cloudflare so i never took care about the private DNS settings in Android.

Btw: did you know that you can shorten the DNS host? try one.one.one.one


#4

Solved it, but had to stop using OpenVPN and instead configure the VPN in Android settings.

https://1.1.1.1/help#eyJpc0NmIjoiWWVzIiwiaXNEb3QiOiJObyIsImlzRG9oIjoiTm8iLCJyZXNvbHZlcklwLTEuMS4xLjEiOiJZZXMiLCJyZXNvbHZlcklwLTEuMC4wLjEiOiJZZXMiLCJyZXNvbHZlcklwLTI2MDY6NDcwMDo0NzAwOjoxMTExIjoiTm8iLCJyZXNvbHZlcklwLTI2MDY6NDcwMDo0NzAwOjoxMDAxIjoiTm8iLCJkYXRhY2VudGVyTG9jYXRpb24iOiJBUk4iLCJpc3BOYW1lIjoiQ2xvdWRmbGFyZSIsImlzcEFzbiI6IjEzMzM1In0=