An error occurred (Unauthorized) when calling the ListObjectsV2 operation

Hi all,

Following the example at https://developers.cloudflare.com/r2/examples/aws/aws-cli/, I’m getting this result:

An error occurred (Unauthorized) when calling the ListObjectsV2 operation: Unauthorized

I have tried using aws configure as well as passing the necessary values by environment variable. I have verified the correct access key ID, secret access key, account ID, and region. No matter what, I’m getting the Unauthorized error. The token is an Admin Read+Write token, and I’ve created several new ones to test.

Was there an undocumented change somewhere such that this endpoint can no longer be called with that set of token permissions? I’m ultimately trying to delete a bucket and its contents with aws s3 rm (the troubleshooting of which is what led me to this point – that command returns the same error).

Thanks.

Upon further investigation I’m getting 401s for my database backups for the past 10 days as well. I don’t think this is related to the current outage since the issues predate it.

I have the same problem with PutObjects.