An A, AAAA, or CNAME record with that host already exists

Hey guys! I’m trying to register a CNAME, but it says it already exists. I deleted this record on my hostgator cpanel then I tried registering it again on Cloudflare but it’s still not working… Do you know what’s happening? What could the problem be?
Thanks!

Welcome to the Cloudflare Community.

Why? If your DNS is active on Cloudflare, your cPanel DNS is not relevant.

The message you cited means that you already have that name in your Cloudflare DNS. If you have a CNAME, no other records are permitted. If you must use a CNAME, you need to delete all other types of records that use that name.

Thanks buddy.

But the point is, there’s no records that use the same name at all, That’s strange…

Can you share a screenshot of your Cloudflare DNS page that shows that error and the existing records? You can obscure the IPs.

Yeah sure. Here go

Thank you for sharing that. I presume there are more records below. The pixel alias is currently returning a canonical name of dns-pixel.ticto.io.

Maybe that’s the issue, thank you buddy!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.