An A, AAAA or CNAME record was not found

Getting-Started

#1

This post contains info on the errors: An A, AAAA or CNAME record was not found…

Causes of this error
This error is caused when there is no relevant A, AAAA or CNAME record in Cloudflare for your domain or www.yourdomain. It can also appear in reference to MX records if one is not present for your domain.

Tips for fixing the error
You will need to add a DNS record pointing to your host for your website to function correctly. The content of the record needed will be available via their control panel or from their support. Alternatively, you could use a tool like this to look up your current records if you have not pointed your domain to Cloudflare yet. Some hosts also have a help article on finding your DNS records so have a look there as well.

DNS record lookup tool (will only show your old records if your nameservers are NOT pointing to Cloudflare)
https://www.ultratools.com/tools/dnsLookup

Tutorial on adding DNS records:

I would also like to reference the relevant community tip:



This is a Community Tutorial, most are wiki posts, so can be contributed to by Regulars and MVPs here, you can view all the community tutorials here. If there is a tutorial you would like to see, you can request one here.

Other great resources on this community include the Community Tips . These address best practices when configuring Cloudflare, how to fix issues you may see, and tools to troubleshoot. Also you can view Expert Tips, great posts on the community that can help users with a similar issue.

We encourage users to check out these great resources and the Cloudflare Support Centre before posting


Subdomain will not resolve
Server not found and use ip
DNS Https not work on my web site
Site not loading after changing the DNS to Cloudflare
Website down, been 3 days?