AMP Real URL - the browser reports a redirect

Hello! I turned on the AMP Real URL mode on Cloudflare and now, when visiting a page from the search, this message appears:
“The page you were on is trying to redirect you to the page https://0-my--domain-ru-0.cdn.ampproject.org/wp/s/my-domain.ru/link/?amp&usqp=mq331AQRKAGYAfu8yLjqi8SH_QGwASA%3D”.
I think this message scares away visitors. Is it possible to make this message not appear in the browser and the user immediately goes to the page with the AMP Real URL?

If you recently activated, you need to wait 6-12hours due to the Gogole AMP CDN cache.

At least, are you using WordPress? If so, do you use official AMP Plugin for WordPress or some other?

There is an option in configuration of the plugin 3 options, do not remember exactly but you can choose to redirect all visitors even desktop and mobile to your AMP version of the Website, or just mobile, or having both “normal” and “AMP” version of your Website - which creates and adds the “link href” with value of “amphtml” to the “head” of your Website…

Also check that your @ and WWW records for your domain in the CloudFlare DNS Dashboard are “Orange” cloud if not already.

Hi! Thank you for your answer! Yes, I recently enabled the AMP Real URL feature, but it’s been more than a day. I also use the official AMP plugin, I have no problems with displaying page data and also no problems with DNS. This notification appears exactly when AMP RealURL is enabled and in the Edge browser (I haven’t seen this notification yet in other browsers). I also decided to do a little research and looked through the search for other people’s sites with AMP Real URL, and when you go to their pages, a similar notification also appeared. If you click on the suggested link from the notification, the page opens with the real AMP URL. Probably some kind of browser security notification is triggered here. Please forgive me if something is not clear from my text, I use a web translator.

Do you have your Website added to Google Search Console?
Once I have had an error when I deactivated one domain on CloudFlare with AMP Real URL enabled, got the Error/Warning about the non AMP Signed Exchanges in Search Console.
Immediately turned back on to the domain to “orange cloud”.
Error dissapeared and issue resolved.

Does the console output some errors too?

Could you please share the URL to your Website and/or AMP article?

Are those AMP URLs have valid AMPHTML code? Have you checked them with the Google AMP tool?

How about Google Chrome on mobile?

Hm, Edge is using the same chrominuim as Opera, as Google Chrome (webkit behind).

Can you try visit some article (all of them have AMP URL enabled on CloudFlare and WordPress AMP plugin installed) on website www.racunalo.com and write back what you got?

Example:
https://www.racunalo.com/xiaomi-slijedeci-na-udaru-americke-vlade-za-blokadu-slicno-kao-i-huawei/

or the AMP URL:
https://www.racunalo.com/xiaomi-slijedeci-na-udaru-americke-vlade-za-blokadu-slicno-kao-i-huawei/amp/

Do you got the same error when you open them?

Or even directly from Web browser on mobile, Google search sometimes it displays results as AMP URL, sometimes as normal URL.

Moreover, if you are using Android, try going to Google News. The same news portal.
Do you got the same error again?

Hi! Thank you for trying to help. My site and AMP pages have been working for years. There are no problems with AMP pages. There is a problem only when switching from the search engine to the AMP page, namely with the AMP Real URL function enabled.

I went to your site “https://www.racunalo.com/xiaomi-slijedeci-na-udaru-americke-vlade-za-blokadu-slicno-kao-i-huawei/” from Google search and the browser also warned me about the redirect.

This is not an AMP validation error or a DNS problem, it is a problem with the security installed in the browser or something like that.

Look at the screenshot of your site (This is not a direct click on the link, but on a query from Google search in the Edge browser)

Weird, but not weird for Edge (ex Internet Explorer) which is based on “Chrome” engine in the background, while this stuff from “Google AMP” work on Google Chrome fine.

Signed HTTP Exchanges are, as staed on caniuse.com, supported by Edge?
Source here: https://caniuse.com/?search=sxg

Here is more about it:

As far as I can confirm, AMP is setup right and CloudFlare AMP URL is working fine.

Short solution, do not use Microsoft Edge :smiley:

Probably because of the automatic translation, I didn’t quite explain it correctly. The Edge browser has no problem with AMP, but there is a problem with AMP Real URL. And this is not exactly a problem. This is a notification that the Real URL changes when you click on the search snippet, so the browser offers to either go to the AMP Real URL or return to the search.

If that so, try changing the Browser settings on your mobile device or just use another one.

Moreover, same problems already here:


https://answers.microsoft.com/en-us/microsoftedge/forum/msedge_search-msedge_android/frequent-redirect-notices-for-google-search/47ac4532-c3fd-41a4-9394-f543e09d585e

I have tested on my Xiaomi Mi Note 10, installed Microsoft Edge browser, tried the same.
I also got the same notification about redirection.
Here, the screenshot:

Finally, this issue is not related to Cloudflare and “Cloudflare AMP URL” option. It’s due to the Microsoft Edge browser functionality.
Please, try writing to Microsoft Edge team directly or Microsoft Support directly. Open up ticket there.

1 Like

It’s great that I’m not alone!)) Initially, the developers of the AMP plugin sent me to Cloudflare. Now I think that we need to contact the browser developers.

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.