AMP Page Settings (Pro Version)

Hello, we would like to know the perfect AMP configuration with CloudFlare, since we have had performance problems, since since we have activated the “Pro” version of CloudFlare we have disappeared from Google Discover, due to problems related to AMP.

We had many problems with AMP and searching and searching we came up with a solution, which is to establish the following rule “https://cultura-informatica.com//?amp” and the problems have been solved.

That alone is fine or do you have to do some other additional configuration?

Thank You…

That’s interesting.

I haven’t experienced this with a Pro plan, neither cannot confirm the Pro plan is the issue here.

I also used AMP Real URL option and WordPress at my domain.

But, in terms of the errors/issues from Google Search Console, I remember in the start when I got first errors, they were related to Rocket Loader (3rd-party script not being allowed back then).

Nvertheless, I have had to create a separate page rule to match my WordPress posts AMP URLs like mydomain.com/article-title/amp/ and disable the Rocket Loader (as it is an external JavaScript file, not allowed by default on the AMP pages - at least in early development of the Google AMP project).

Therefore, I kept everthing else in plcase, Minify option, Polish, Mirage, even got Cache Everything option enabled with the Page Rule for the /amp/ URLs working perfectly fine.

I might not vote for ?amp due to SEO reasons, rather would configure, if you can, to have /amp/ using to AMP for WordPress plugin or some other, if so.

What errors did you get in GSC dashboard?

Hm, due to this one, I remember it is related to Google AMP URLs and also with, may I ask is your domain valid and successfully added and still existing at the Google Publisher Center (Google News) https://publishercenter.google.com/ regarding this?

Nevertheless, there are some strict rules and guidelines either for Google News (only the posts from last 48 hours), Google AMP (good setup, no errors at least, ok if warnings but can be fixed) and Google Discover (only the Google knows how this algorithm works at all, nor not).
The one common rule which I do remember and you have to follow it for all of them is using images which are at least 1200x675px (width x height) for your WordPress articles.

And, not an easy way and fast process to get in. I’ve remember first time I was rejected 3 times in a row due to some issues, which I have had to fix. It took me up to 6 months to get it right. Since then, even when COVID-19 started and the review process took longer time to apply, up to 3-4 weeks. And boom, again you got some error :slight_smile:
So, it’s really not easy to comply with all at first moment.
And yes, there is a difference in applying, at least as of back few years ago when we applied, and nowadays (2 years ago), even a lot changed and they merged/rebranded the name of Google News, etc.

Furthermore, I am afraid Pro plan is not the issue here.

Hello, everything mentioned we have done well, everything. The problem appeared when we started using Cloudflare Pro and Argo, I don’t know what happened.

Previously we appeared a lot on Google Discover but now nothing at all.

I don’t know if we have implemented something wrong in the AMP version or some additional configuration

Weird a bit.
Why would it be so?

Well, again, I am not sure who could know how Google Discover recommends / suggests your links and articles to other consumer/readers of it on Android.
That’s not the thing we could manipulate, neither Cloudflare can do something good, or hm, bad in your case as you state.

Please, check your Google Search Console if there you have got any errors/warning related to the AMP links.
If so, kindly review how to fix them - usually it says what’s wrong, therefore we Google to find solution.

I am afraid Cloudflare cannot be the here to blame.

From my case, as stated, I have had to do a little change due to the Rocket Loader (as an external script).

Otherwise, I am not sure but if you still think Pro is the issue, try to switch to Free plan temporary for a month and see what happens? I am not sure what other to suggest to you.

You could try to turn off the Mirage and Polish options, even Rocket Loader, as from my point of a view what could be, but I doubt it is, and watch for next 7-14 days what happens, if so.

Again, try using the /amp/ instead of the query part ?amp.

Nevertheless, you suggested yourdomain.com/?amp either yourdomain.com?amp redirects me back to your normal page, which is not the AMP HTML valid either.

If you have AMP configured for your homepage?

Otherwise, the article links like https://cultura-informatica.com/aplicaciones/whatsapp-desktop-stickers-store/?amp opens up the AMP webpage as it is supposed to.

If only the valid AMP links and webpages are used for Google Discover - I do not know for sure - then I am afraid something is wrong with your WordPress for AMP plugin?

I see the images for example https://cultura-informatica.com/wp-content/uploads/2021/12/WhatsApp-Web-Stickers-Store.jpg is good, 1200x675px.

I also se it’s a valid AMP article(s) at least in Google Chrome using Developer COnsole https://cultura-informatica.com/aplicaciones/whatsapp-desktop-stickers-store/?amp#development=1:

Powered by AMP ⚡ HTML – Version 2111152338002
AMP validation successful

Also using the online validator tool here:

Other idea, maybe you are blocking Google bot or it appears in your Firewall Events of Cloudflare dashboard for your domain name? Can you re-check this?

Furthermore, my Search Results, Google Discover and Google News are all different each day. Some days are where I do not have any Google Discover / Google News at all, 0 zero.

See here:

Who knows how Google Discover works.

I have one domain which has very low Google Discover mostly, then suddenly few highs.

This is not clear to us … I could not explain better, thank you

Did you just switch to AMP?

No, AMP was already implemented previously

May I ask, did you maybe applied for or enabled the SXG beta option in Cloudflare dashboard?

Yes, it is enabled

Hm, unfortunately I am afraid that is the main reason why your AMP pages could be broken or makred with the errors in your Google Search Console.
Therefore, if the Google Discover/News used AMP pages, it could also be the answer why you do not have any traffic to see on Google Discover in Google Search Console.

See below link, or rather the cite with the link to the topic here:

Link to the topic:

Hello, thank you for your valuable help.

Previously, we had seen many errors in the Google console about AM pages, so we established a rule in Clouflare that everything will be loaded into the cache, that worked and corrected the errors. We do not know if it is the best procedure.

Then, we do not have the “AMP Real URL” option enabled in CloudFlare, but we do have the SXG option enabled.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.