Amazon ses dkim failing

I have tried the following and it failed twice. It’s frustrating.

I also tried.

It just says pending or keeps failing. What am I doing wrong. I never incurred such an issue before.

What exactly do the instructions say to create?

You currently have the second batch of records configured but their targets do not seem to be what Amazon expects.

The first batch of records actually seems all right. Try to reconfigure your records and post back here once that is done.

I did the first batch twice and both time failed. It’s getting frustrating.

Well, its still not set accordingly.

I have done it correctly again as Amazon stated. Please let me know if there is any error you may see or something I am not doing correctly.

Looks all right. If Amazon still does not recognise it I would contact them and ask for clarification.

NThe instructions say that verification can take 72 hours, so perhaps waiting a little while would work?

Hi - I’m reviving this older thread.

Is there any known solution to get DKIM verification to work with Cloudflare?

I am facing the same issue and most support posts end in silence.

How was this problem solved @arfan?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.