Always Use SSL Missing

Hi, how are you?
I am using cloudflare and it is great. Have a question. I try to create a Page Rule and set to…
“Always Use SSL”, but that option is not available on the dropdown. How to add it or make it visible? Thks…
Joe

Is SSL active for your domain?

Can you post a screenshot of your Crypto page?

Hi: in reply to yuor question, these are the details…

  • this is Cpanel view, since I am using Cloudflare as a Cpanel plugin with no DNS change…
    https://prnt.sc/nh63l6

  • I am using Wordpress, and the Cloudflare plugin + Really Simple SSL Plugin;

  • this is my Crypto page… how to configure it? Thks…

I assume your certificate has not been provisioned yet and hence you cant enable that option yet. Wait 12 hours and then check again. If it still does not work open a support ticket.

Also, you currently have Flexible enabled. That option should never be used and makes your site unsecure. You should make sure you have a certificate on your server and switch to Full Strict -> Why we recommend you don't use flexible!

Dear Sandro: thks for your great support… In reply to your ticket, pls consider this…

  • I had set this more than 2 days ago and still not working;
  • about Flexible, it is the way it is explained on all Wordpress forums and videos, and in other sites it is working, that is why I made it with Flexible;

Take into account I am using Free plan, I had not buy a certificate. How could I fix this, to add the page rule missing?
Thks…

Could you also post a screenshot of your overview page? But you’d likely want to open a support ticket at this point.

I am afraid these “tutorials” got it virtually all wrong. Flexible is a bad choice, please refer to the article I linked to earlier.

Hi Sandro: awesome support. My last questions are…

  • can I still open a support ticket if I dont have a paid plan on Cloudflare?
  • do you have a similar tutorial or topic, but for setting up wordpress SSL?

Thks a lot!

Yes, you can. Response times will be just longer. https://support.cloudflare.com/requests/new

I am not all that familiar with Wordpress, but I would assume it shouldnt be much different from any other webserver setup. Simply make sure your webserver is responding properly on port 443 and has a valid certificate and that you can browse your site on it also without Cloudflare and you should be good to go.

The tutorial section here on the forum might have even more details however. I’d highly recommend it, @domjh put a lot of effort into it :slight_smile:

1 Like

This topic was automatically closed after 31 days. New replies are no longer allowed.