Always use https was working and now is not

The always use https rule has always worked perfectly for me and now does not. I ran diagnostics and got “Check the HTTPS status: Looking good.”
My two domains are both having this issue: www.eventprints.com and www.presentech.com. You can type in https: and be secure but does not automatically load. Any ideas? Thank you!

I see that they’re not redirecting to HTTPS.

At the bottom of your DNS page here, can you confirm that both domains are using the Alan and Lana name servers?

Are these sites on regular hosting plans? Or are they hosted by an e-commerce full-service host (Like Shopify, etc).

Seem you are using a VPS running nginx, so open the config file and look and change the config to something like this:

server {
    listen 80;
    server_name eventprints.com  www.eventprints.com;
    return 301 https://$host$request_uri;
}

Just change the block server listen port 80, other things leave it as it is

How do you expect port 80 to work with HTTPS?

if it is http / port 80, then it will redirect 301 to https

The proxy will already cover the redirect, so there’s no need to bother with that.

1 Like

But it’s not. The server redirect should take care of that until the proxy problem is fixed.

1 Like

Configuring HTTP to cover for a broken Cloudflare setup is a bit counterproductive.

In fact, in some cases, when Cloudflare’s http to https redirect is not properly configured and it conflicts with hosting, it will lead to a redirect loop. That’s why I recommend he redirect right from hosting and not on Cloudflare.

A redirect loop only happens when you have a broken security setup. It’s best to redirect at the proxies and not even run port 80.

I find it better to do the redirect at Cloudflare. It’s faster and takes that load/responsibility off the server.

If the “Always Use HTTPS” isn’t working, which I don’t know why it wouldn’t, an alternate would be to use a Page Rule for http://example.com/* with a Forwarding Rule (301) to https://example.com/$1

1 Like

Yes, name servers are correct.

We are hosted by an eccomerce site, 3DCart, now known as Shift4Shop, which is a Cloudflare associate.

So, there was a lot of back and forth on this solution - not sure what the final decision is. Thanks!

In that case, I bet the Cloudflare settings are really controlled by them. I suggest you contact their Support and see if they can get that working again.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.