Always Use HTTPS Setting Causes Two 301 Redirects

ssl
https

#1

Hello,

My Wordpress Home and Site URL are set to https://www.resurrectedhair.com

I have installed a Let’s Encrypt SSL certificate on my origin server under resurrectedhair.com and www.resurrectedhair.com. I disabled (commented) the redirect https permanent syntax in my apache virtual hosts file as well as HSTS.

When I enable the Always Use HTTPs in Cloudflare and test the number of redirects per this website: https://httpstatus.io/ using the naked domain resurrectedhair.com, I get two 301 redirects.

However, if I use the sub domain www.resurrectedhair.com there’s only one redirect.

Is this normal?

For the life of me, I am really confused on what domain name I should use when I conduct any online security, SEO, or speed test. For example, if I have this setting enabled, to prevent further confusion/false positives, using Pingdom, do I use www.resurrectedhair.com or resurrectedhair.com?

Also, based on my configuration, if someone types resurrectedhair.com he/she will be redirected to www.resurrectedhair.com. What kind of an affect does this behavior have on SEO, Google indexing, etc.? Would I be penalized as having two 301 redirects if someone types resurrectedhair.com to be redirected to www.resurrectedhair.com?

Lastly, what domain name should I add to the Google Search console here: https://www.google.com/webmasters/tools/home?hl=en. I am thinking since my WordPress site is named under www.resurrectedhair.com, that’s the name I should use with a preface of https.

Thank you so much for looking into my questions. This definitely means a ton!

All my best,

Joe


#2

since you’re redirecting people to www.resurrectedhair.com that’s your site. There’s nothing at your bare root but a redirection to the site which is www.

I only see one redirect… connecting to http://resurrectedhair.com redirects to https://www.resurrectedhair.com, not sure where/how you have the two redirects you mention.

I would speed test and SEO test against your site which is www and since you only serve the site over SSL, https:// would be the scheme I’d use.


#3

Hey cscharff,

Thanks a bunch for responding so timely.

I apologize but I must have had the setting disabled in Cloudfare. Test it now as I see two redirects under resurrectedhair.com.

Awesome. I am gonna stick with https://www.resurrectedhair.com for all online scanning sites as well as for Google’s search console.

Thank you so much for clearing up this confusion. This was really causing me a big migraine!

Let me know if you see the two redirects under the naked domain.

All my best,

Joe


#4

That’s gonna happen if you use ‘www’. The first redirect makes it HTTPS. The second redirect sends you to www. This is what’s happening now for your domain (I just checked).

In my case, the reverse happens since I don’t use www. Someone who types in www.example.com will get a first redirect to HTTPS, then a second redirect strips off the www.

The good news is Google’s search results will get it right. If someone Googles for My Cool Product, the link will send them directly to https://www.example.com/mycoolproduct


#5

Hey sdayman,

Thanks for the in-depth explanation. This makes total sense.

So, the consensus is my current Cloudflare and origin server set up is correct then?

And as far as adding my site on Google Search Console, like I mentioned to cschariff, I should just set it as https://www.resurrectedhair.com, correct?


#6

Your Cloudflare and server settings are working as expected.

For my Google Search Console, I have ONE AND ONLY ONE entry per website. (sorry for the shouting). I know there are some confusing instructions to add every combination for your website, but I believe that’s only if it actually uses that URL. With your/my redirects, visitors will use ONLY ONE URL: https and your www (or my non-www) domain.


#7

Got it. Thank you so much man. You’re a true blessing.

I will set it as the full domain including the www subdomain.

Take care!

All my best,

Joe


#8

This topic was automatically closed after 14 days. New replies are no longer allowed.