"Always Use HTTPS" Not Working

I enabled CloudFlare SSL (Flexible setting) and enabled “Always Use HTTPS” but whenever I go to my site, e.g.

http://www.abdullahyahya.com/blog/

I never get redirected to https.

If I manually go to https://www.abdullahyahya.com/blog/, I get the following error

This site can’t provide a secure connection

www.abdullahyahya.com uses an unsupported protocol.
ERR_SSL_VERSION_OR_CIPHER_MISMATCH
Unsupported protocol
The client and server don’t support a common SSL protocol version or cipher suite.

Am I missing something?

That hostname isn’t going through Cloudflare. Not without the www either. Those DNS entries are probably set to :grey:

1 Like

Thanks! I forgot I had disabled the Cloudflare proxy in the DNS settings. It would have been nice if Cloudflare auto-detected that and put up a notice or something.

It’s working now. Thanks again!

1 Like

A post was merged into an existing topic: SSL not secure

This topic was automatically closed after 30 days. New replies are no longer allowed.