Always use HTTPS not working


#1

Im using a page rule to enforce https on my site, but its not working. Yes, I’m securing my traffic thought cloudflare. I can access https://laurosilva.com but when I access http://laurosilva.com it does not redirect to a secure https site.

Any idea how to fix this?


#2

You can force SSL on the crypto tab without using a page rule by selecting “Alway use https” instead. But your page rule does not match http://laurosilva.com which is why it isn’t being forced to SSL currently.


#3

Thank! I turned on Always use HTTPS from the crypto tab.

Btw, how should my pages rules match to force SSL?


#4

Update: After turning on Always use HTTPS, my site is still not redirecting to https. Its a static site hosted on GitHub. What am I missing here?


#5

It’s working fine for me in Chrome. Are you still having issues?


#6

i cannot find “Always Use HTTPS” as part of the page rules. Any help would be helpful.


#7

“Always Use HTTPS” option will only appear if your zone has an active SSL certificate associated with it on Cloudflare. So you need to wait till the SSL certificate is issued and activated there.