'Always Use HTTPS' not working at all

I’m trying to add my .com site to HSTS preload at https://hstspreload.org. I’ve already correctly configured Nginx and my site gets submitted to the preload list. However, enabling Cloudflare for the site causes this to fail, and it shows that Cloudflare is not redirecting from HTTP to HTTPS.

My Cloudflare settings:

Crypto

  • SSL - Full (Strict)
  • Always Use HTTPS - On
  • HSTS - On

Still does not seem to redirect to HTTPS according to HSTS Preload . I can’t even use page rules since the ‘Always Use HTTPS’ option in the dropdown is grayed out. Pausing Cloudflare is the only solution I can find right now that passes the requirement at HSTS Preload .

Did you go to the SSL/TLS settings and enabled it there? Unfortunately without knowing the actual website we can’t help…

Having it active via the global rule prevents the page rule to work, since they are the same thing.

This topic was automatically closed after 30 days. New replies are no longer allowed.