"Always Use HTTPS" not Redirecting

Under SSL/TLS > Edge Certificates: I activated "Always Use HTTPS"

However, my domain stays on http many times.

I have read previously this could be a “mixed content error”, though I have been unable to find any issues in the code.

This is a static index.html file website: deflatex.com/

Same issue as 301 redirect page rule not working

I have read through your reply but still unable to understand steps to fix this:

“Your naked domain is not proxied, hence the page rule wont fire. Given that it points to a service which already is on Cloudflare you wont be able to proxy it however.”

My domain is on NameCheap. I originally updated the CNAME + TXT records there to cloudflare.

However, when I created a cloudfare account, it told me to also create custom Nameservers (arya + ethan)

When I updated the nameservers to Cloudflare, it removed my CNAME + TXT records. So I have done them again here directly on Cloudflare.

What steps do you suggest to fix this?

The issue is not the nameservers. The issue is your DNS records and where they point to. Your site is hosted on a service which is using Cloudflare itself, hence you cannot proxy these addresses, hence none of the settings will take effect. All you could try is follow the recommendation I posted last.

" The only thing that might work is if you set up your domain on the “www” record and redirect all naked domain requests to “www” as outlined under Redirect example.com to www.example.com. Requests going to “www” with that path still wouldnt be redirected by Cloudflare however.

I’d recommend to go through support.cloudflare.com as that will clarify most of your questions."

Is this the recommendation you’re talking about? I have talked to Namecheap a few times who keep telling me to talk to Cloudflare as they don’t control my hosting. Very frustrating.

Namecheap is your registrar, not your host.

Yea, I never implied that Namecheap was my host. I am using IPFS, which is a distributed and decentralized host, that of which I thought Cloudflare communicated well with.

So, is the above quoted reply what you’re referring to as your ‘recommendation’? Would I do this directly on Cloudflare or Namecheap?

Well, you did mention Namecheap and Namecheap is quite irrelevant in this context.

The whole issue really is already covered in that other thread.

You will have to proxy your records if you want your settings to take effect. You dont seem to be able to do so, as your service provider is also using Cloudflare and hence you cant proxy. Either change host or you have to make the HTTPS redirect directly on your host’s side.

Appears the other person was not able to be helped with the information you provided there either. Seems like a trend, will await to see if anyone else is able to provide insight.

Excuse me?

I explained the situation to the other poster and to you as well. If you dont want to accept the technical facts, there is no helping you I am afraid. :roll_eyes:

As @sandro mentioned, your website points to a 3rd party service hosted on Cloudflare’s edge. In this case I know who the service is hosted by… it is in the name of the target for your root and www records.

Since you are pointing to that service hosted on Cloudflare, that service controls the settings for the domain in question. That service doesn’t automatically redirect http to https. So even though you have set that for your zone, your zone doesn’t control the behavior for that particular record.

If you highlight the :large_blue_circle: next to those DNS records you will see they are managed by another service as well.

This topic was automatically closed after 30 days. New replies are no longer allowed.