"Always use HTTPS" not enabled

I get this warning even though “Always use HTTPS” is enabled, and there is a valid 301 redirect.
Here is the error in Security Center:

And here is the result from securityheaders.com without following the redirect:

And this is the SSL/TLS Edge Certificates setting for the site:

When did you enable it? It looks like from that screenshot, that scan/report is from ~10 days ago, on the 16th May.

If you’ve since fixed it, then it shouldn’t show as an issue again in the next scan/report.

That could be the issue, but it seems like new scans aren’t updating the results.
But the date on the results is sill May 16th.