Always Use HTTPS missing from Page Rules after error

I need a bit of help here, and any provided help would be much appreciated. Normally I am able to research my own fixes, but this one has me stumped. I have the free Cloudflare account with 3 domains. I added a page rule to all the domains for "Always Use HTTPS " and it worked great. Later, I was trying to debug some site issues and turned it off for one of my sites, and when I turned it back on, it threw an error. I think it was a 1004 error. It wouldn’t let me turn the page rule back on. So I decided to delete the page rule and try to re add it, but the option "Always Use HTTPS " was missing from the list, even though there are no page rules on the site. Thinking this might be some weird database error, I even removed my site and re-added it thinking that might fix it, but the setting was still missing when I re-added the site to Cloudflare. I still think this might be some weird database issue, but of course I can’t get any support because I am on the free plan.

I also found this tech article that says that the option “Always Use HTTPS” is available under SSL/TLS > Edge Certificates, but I don’t see it. Perhaps this is outdated documentation or not available on the free plan.

[Link to Support Doc](

What am I missing?

I went in there again and the option is now there. I switched it on and I saw the page rule option again as well. This issue is resolved.