Always use HTTPS doesn't work when I key domain name directly


#1

My website is a blog via Wordpress, the address is pewpewpew.cc - I have everything set up as guides online have taught. The links within are https, and if I key in https it works, Chrome shows a green lock.

But when I access pewpewpew.cc (or any pages with http:// directly) it still reverts to the non-HTTPS version, even though the links within are HTTPS.

I set up a page rule (http://*pewpewpew.cc* - Always Use HTTPS), Always Use HTTPS is on, Automatic HTTP Rewrites is on. My .htaccess doesn’t have any redirect.

Appreciate if I could get any help, thank you so much!


#2

Works for me:

curl -I http://pewpewpew.cc
HTTP/1.1 301 Moved Permanently
Date: Wed, 13 Jun 2018 15:36:31 GMT
Connection: keep-alive
Cache-Control: max-age=3600
Expires: Wed, 13 Jun 2018 16:36:31 GMT
Location: https://pewpewpew.cc/
Server: cloudflare
CF-RAY: 42a5a219c0df7f0c-SFO-DOG


#3

I’ve tried to repeat this on multiple browsers (Opera, Edge and Chrome), tried clearing all cookies and caches, and used incognito modes as well. All of them have returned that the site is insecure. Could this still be a client side problem?


#4

27

Does your sitte resolve to the Cloudflare IPs from your machine?

dig pewpewpew.cc +short
104.31.81.195
104.31.80.195


#5

That’s a good question! I tried pinging the domain, but then it resolved to 198.252.101.150, that seems to be the IP address of my web host. I only changed my name about 7 hours ago, could that be the reason why?


#6

Likely. It may be that your DNS provider has the old value cached. You can try flushing your local machine’s cache and/or that of your router.


#7

thanks! that was indeed the case :slight_smile:


#8