Always use https doesn't work properly

dash-dns
dash-crypto
#1

Hi,

On Cloudflare, I have “always use HTTPS” enabled.

If you go to my website, http://marketersedge.com/ - you will notice that it automatically redirects to https://marketersedge.com/ - this is exactly what I want.

However, I have noticed that if I type in any specific pages on my website (for example, http:// my site / home) it will NOT redirect to https://

This is the case with ANY specific page links that I put after the domain. I’ve pretty much tried everything at this point (page rules, etc) and can’t seem to get this to work.

Does anybody know how to fix this? My site is hosted with Clickfunnels, has SSL integration, but just doesn’t seem to work properly on page links. I want to pretty much completely disable http:// and only use https://

Thanks a ton!

#2

I could only post 2 links in the original post. Here’s a correction:

• However, I have noticed that if I type in any specific pages on my website (for example, http://marketersedge.com/home) it will NOT redirect to https://

#3

If it’s Clickfunnels, it’s probably supposed to be a CNAME setup where you’re supposed to use www instead of the apex domain. If I do the same URLs, but with the www subdomain, it redirects properly.

It also looks like DNS for the apex domain looks broken, as it returns four IP addresses instead of just two, like www does.

#4

Got it. Thanks a lot for your answer.

I suppose you’re right. If I use www, it always uses https://

So I guess my question now is, is there any way to have it always uses www?

My intention is to permanently always have https:// enabled.

Thanks again!

#5

Set up a Page Rule:
Match: marketersedge.com/* and add setting: Forwarding URL (301) https://www.marketersedge.com/$1

The $1 will forward the path from the * wildcard match.

#6

Thank you.

I attempted and it still doesn’t seem to re-direct. Super weird.

I expected that to work.

Example, if you go to marketersedge.com/home/ it still doesn’t redirect to https or www

#7

Here’s more info if this helps,

DNS settings: https://puu.sh/Diz8k/22af9d8b72.png

Page rule: https://puu.sh/Diz80/5472912649.png

#8

Thanks for the DNS screenshot. That explains the weirdness I noted earlier.

Make www a CNAME to target.clickfunnels.com
Get rid of the CNAME entry for marketersedge.com
Then create an A record for marketersedge.com with an IP address of 192.168.1.1 (just as a placeholder, since the Page Rule will intercept this). Make sure it’s set to :orange:

That should do it.

2 Likes
#9

When I try to make an A record for 192.168.1.1, it says “this DNS record cannot be proxied”

Anything other option or IP I can put there?

#10

Darn, sorry. Just go with 8.8.8.8.

#11

Okay, so we’re making some progress…

Now, the domain always does redirect to https://

That’s what we want!

However, the actual site doesn’t work now, lol. If you go to https://marketersedge.com/, it doesn’t direct to my Clickfunnels site

#12

New pictures:

DNS settings: https://puu.sh/Dizxd/f5ae4a889c.png

(just pay attention the A record and Clickfunnels record, the rest doesn’t matter right now)

By the way, I really do appreciate your help and time man. Thanks a lot.

#13

I’ve not used Clickfunnels, but does it have a setting for which domain it’s using for you? Perhaps you need to tell it that you’re now using www instead of just the naked domain.

By the way, why was your site set to use /home instead of the root directory?

#14

Holy moly. I think I got it working.

Just did some messing around… and did exactly what you said but switched it up just a tad.

I put marketersedge.com for the CNAME, and A record to www, and it seems like it always is https:// now

This is pretty much all thanks to you. Thanks a lot man.

Edit: in reference to your last question, no idea. i’ve been messing around with this thing all day

Edit2: Now it’s not working again. I have no idea at this point. Going to contact Cloudflare & Clickfunnels support

#16

It looks like it’s working. So let it settle for a bit. Hopefully what you did will keep it working.

#17

I swear it was trolling me. It was working flawlessly and now back to the same issue.

Going to mess around with it and see if I can figure it out

1 Like
closed #18

This topic was automatically closed after 30 days. New replies are no longer allowed.