Always Use HTTPS But Website Still Not Secure

I have turned ON the settings on Always Use HTTPS last night but when I visit the website I still get the Not Secure label beside my domain name. Can anyone help?

The website is http://jobstartsummit2022.ph/

The redirection is working as expected. If the browser is still throwing a ‘not secure’ label, click on that label to see if it provides clues about the reason. It may be your browser cache.

image

1 Like

Whn I click on Not Secure label, it says: Your connection to this site is not secure.

1 Like

Can you Share a Screenshot and which browser are u using ?

I have attached it here. Not sure where the error is coming from.

image
It’s showing as secure in all browsers I try.

Go to Chrome > Dev Tools > Application and delete all caches you may see there. See if that does the trick.

If not, disable all Chrome extensions and try again.

BTW, I found it odd that your browser would at the same time say it’s not secure, and that your browser is set not to show any warnings!
image

1 Like

Thank you for confirming that the website is indeed secured by Cloudflare. I have deleted cache and turned off extensions but I am still seeing the not secured label. I also used Safari browser on phone and still getting the same issue. I will try again later with a different internet connection and hopefully I will get the secured website. Thank you for your tips!

1 Like

The test below sees that your site supports protocol 1.0 and 1.1, which are considered not safe. Please go to https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls/edge-certificates and for the options Minimum TLS version, please select 1.2. I hope that solves your issue.

https://www.ssllabs.com/ssltest/analyze.html?d=jobstartsummit2022.ph&s=2606%3A4700%3A3032%3A0%3A0%3A0%3Aac43%3A88eb&hideResults=on

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.