Always on is not working

Hello,

I am using the following rules

https://www.businessnews.gr/*
Browser Cache TTL: a day, Always Online: On, Cache Level: Cache Everythings

I was expecting my site to be always on but it does not. If there is a problem on the origin server then the site goes down.
Have I understand something wrong?

Certain errors won’t trigger Always Online:

I am getitng error on my home page 524 timeout
Isn’t this error on those that always online handles?
If it is not is there a way to ad it ?

Then it’s possible it hasn’t crawled your site. Does the 524 error screen say anything about Always Online?

This is a screenshot

It looks like it’s completely ignoring Always Online. Have you tried enabled it from the Caching page?

How do I do that?