All Subdomains redirect to TLD or give Error after switching to SSL


#1

Hello…Im really frustated. All my LEVEL1 subdomains that previously worked, ceased working when I got the Universal SSL working on cloudflare. I have tried flexible/full and I even tried to undo the https: but nothing gets it to work right. Previously when everything was just http: all sites and subdomains were accessible. Now only top level domain works and only on https: (cant reverse it back to only http:) So I am stuck in limbo…

I tried some htaccess modifications…nothing worked.
I dont use cpanel… I use a control panel called webuzo which helps me manage my sites. (I dont think it matters too much) but if anyone can explain to me what is going on I would really appreciate it.
Thank you
-B


#2

Can you post a subdomain that’s not working?


#3

Sure! daniels.xtarmark.com just goes to xtarmark.com


#4

my.xxtar.com goes to xtarmark.com as well
but TLD xxtar(dot)com works fine as it should


#5

really cool avatar…


#6

my.xxtar goes to an OwnCloud installation, so the xxtar domain seems to be working properly.

daniels gets a 301 redirect to the root domain.

Is xtarmark a WordPress Multi-Site installation? I’m trying to think of reasons daniels would redirect to the root domain.

I would suggest you switch the daniels DNS entry to :grey: so it goes directly to the server, then see if it still gets the redirect.


#7

No…xtarmark.com is not multisite… but it is the “main” site and all the other ones are subdirectories


#8

How the heck did my.xxtar.com just start working? Did you do something? I swear it wasnt working before… Ill try and retrace my steps


#9

“Subdirectories”? Or are they *subdomains*?


#10

Daniels is a subdirectory…it has it own wordpress installation…and it has the identical named subdomain…


#11

some of the other subdomains just go to a “white screen” now…which is giving me the impression that the browser is blocking it because there is something unsecure in the connection


#12

This makes me think it’s a server configuration issue. Servers usually have separate configs for Port 80 and Port 443, so odd configurations (like Flexible) are going to confuse them.

As always, the best way to configure SSL is to get it set up on the server first; make sure it works without Cloudflare, then put Cloudflare on top of it.

Can you put SSL certificates on your server for those subdomains?

This would be awesome if you could do it with a Cloudflare Origin certificate:
https://www.webuzo.com/docs/endusers/install-ssl-certificate


#13

You know… on the my.xxtar.com subdomain …I installed a cloudflare certificate… and that is the one that is working… please tell me this…does it take “time” for it to work…because maybe I checked too soon and just thought it wasnt working when it really was.

Im starting to think that the “other errors” php errors and stuff are a seperate issue because I had upgraded from php 5.4 to 7.0 when I “thought” the ssl was working right… but maybe all I need to do is put the ssl on the site and then fix the php problems


#14

It shouldn’t take too long before Cloudflare recognizes that Origin Certificate. I’d wait 5 minutes…and make sure you’re using SSL Full (Strict) mode.


#15

I wasnt using strict because the certificate is from cloudflare…


#16

I got the certificate from the spot where it said origin certificates
(if you can see the picture I pasted)


#17

Cloudflare recognizes its own Origin Certificate as valid so you can use Strict. The article above mentions this.

You don’t need all those subdomains in the Origin Certificate. Just put in example.com and *.example.com (but with your real domain name). The wildcard is valid for any subdomain.


#18

Ok but to be clear…

if my main domain is example.com… a subdomain would be Hello.example.com
is xxtar.com considered a subdomain? its a top level domain running off the same account…
I just need to know do I go to the xxtar.com cloudflare entry and create a seperate certificate.


#19

H Sdyman… hey Im sorry… I hope you dont think I am rude. I really appreciate all your help. Because I am new…after so many replies on our thread…the system banned me from responding for 24 hours. So I could not talk any more. I hope I dont run out of replies today…


#20

xxtar is a domain. hello would be a subdomain. So * covers hello, but will not cover www.hello (a sub-subdomain).