All posts cached as 404 in wordpress site

Since yesterday all posts on my WordPress site are cached as 404, and purging the cache does not solve the problem. When development mode is enabled on Cloudflare, everything is fine.

1 Like

That sounds like this unresolved thread:

It’s very difficult to diagnose remotely, so I suggest you open a support ticket, then post the ticket number for the moderators to keep an eye on.

To contact Cloudflare Customer Support, login & go to https://dash.cloudflare.com/?account=support and select get more help. If you receive an automatic response that does not help you, please reply and indicate you need more help.

Maybe it’s a problem with Automatic Platform Optimization with WordPress, now I have it disabled and the 404s do not show up anymore.

My website is in Chinese and the website you mentioned is in Arabic. Maybe it’s problem about non-ascii encoding in URL?

2 Likes

Interesting. I wonder if @yevgen has heard of such an issue.

hello everyone
i have created ticket , but response is so late from support
still waiting for response

1 Like

Please post the ticket number, I can have a look.

I am having the exact problem, website in Chinese (permalink in Chinese as well), and all cached page return 404 when APO is enabled.

1 Like

this the ticket nu #2102631

1 Like

I have this issue too, just by disabling APO problem solved !

The main problem is APO, after disabling that, problem solved !

we will rollout a fix, should be live in 4-6h.

3 Likes

is it fixed now ?!
8 hours !

yes, it should be fixed now, try it.

2 Likes

Thanks, It’s OK now :blush:

1 Like

you can’t trust the 404 errors in search console now, first of all, purge all cache, then enable APO, the errors in search console will disappear soon.
by the way, i checked your site http header, apo is not working.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.