All of a sudden ssl is not resolving with shopify

Everything was fine until about 11am this morning. Ive redone the cname and a records to no avail ssl is unavailabe as far as shopify says it’s not resolving on the back end and if someone attempts to put something into my cart they get an insecure error. This is great the week before xmas. Been with shopify techs for 4 hours they say its a cloudflare issue. What do I do? I dont see a way to contact shopify

Make sure that your website’s DNS records here are set to :grey: DNS Only. That will send requests directly to Shopify’s connection.

I tried that. it didnt’ help

Leave it set to :grey: and then Shopify needs to fix this.

For them to blame it on Cloudflare is to blame themselves, as Shopify has a custom Cloudflare setup. Just make sure your website’s hostname is set to :grey: DNS Only. Cloudflare customers who use Shopify are not supposed to Proxy :orange: their connections to Shopify.

So they have a connection with clodflare but that shopify connection allows a billion bots through and gives shop owners no control, so I hooked the site up With cloudflare independantly. It’s been working fine for months until 11am this morning. ssl is listed as unavailable on the shopify admin / domains. All my settings on cloudflare are correct and shopify says that it’s not working on the back end. How do I just remove my domain from cloudflare. I’ll go back to my registra and reset the dns etc and start from scratch

from shopify:
I understand how important this store to you however, the error that you have encountered is something to do with the DNS on the back end.

Please take note that we do not have any holds with the DNS management since the domain name is not pointing to us. All the DNS management is now with cloudflare. If the A record , CNAME record or any other records, is not resolving, this needs to be checked through Cloudflare.

would suggest to revert the name servers to the original name servers prior to Cloudflare and make sure that the A record and CNAME record is pointing to us.

I looked at ssl on cloudflare it says Your SSL/TLS encryption mode is Full Now there’s some type of certificate link in the menu that I’ve never set up (but never needed to again this was fine until 11am this morning) Is this something new that I HAVE to do? I’m so confused and of course have not gotten orders since this morning because adding to cart is throwing a not secure error

And of course, Christmas took everyone by surprise and no one knew it was coming so… everyone needs to hurry up and shop on December 15th and then want to choose 1st class and tell me to make sure they get it by Christmas. so at this point I’m just totally wanting to roll up in a ball and cry.

I feel your pain.

Can you post a screenshot of your DNS records here? I don’t expect there’s anything secret there.

Read on for the nitty gritty…
Almost no settings at Cloudflare matter, except DNS. All you’re doing is point your hostname to Shopify so it’s a direct connection. SSL is handled by Shopify through their Cloudflare account, but if you post that picture, we can help troubleshoot where SSL is broken.

If you go back to your registrar, you still need whatever DNS you use to point to Shopify, which will 99.9% most likely have the same problem you have right now. Plus changing name servers can take up to 48 hours to complete.

Still reading? Ok. A picture of your old name server’s DNS records will also be helpful if you can provide that. That way we can see what used to work, and if anything has changed.

posting things make me really uncomfortable is there a way I can pm you? assuming this message board has some type of private message system

I see that your ‘www’ CNAME points to Shopify, then redirects to the root domain, and loads. And I see shopify all over the place in your page code. Is the below screenshot your Shopify site?

that is my site but if you tryp to put something into the shopping cart on chrome you get an error saying its not secure and my cname still doesn’t resol
ve to anything

If I go to and search for cname on it’s all x and shopify still shows my ssl as pending. And apparantly since I’m a new user I cannot create any more replies in this forum and it said I have to wait 17 hours.

I’m going to have to keep typing here, I hope you see this. You show me below that you added something to the shopping cart. Is that on chrome, cause I’m still getting an insecure error on both chrome and opera

And you can live chat me on my site if you want

console is blank network says blocked other and clicking it shows " failed to load response data"

it seems the add to cart button is going to http instead of https but I’m assuming that’s because the ssl is not connected in shopify admin (and still pending) so all the add to cart buttons are going to http
I am really perplexed to know why this happened out of the clear blue sky for no reason

And I’ve never ever seen anything take more than an hour or so to propagate.
So I thought this was the private chat thingy lol can you remove the screenshot of my website please

Cloudflare flattens CNAMES of root domains because you’re generally not allowed to CNAME a root domain. So Cloudflare works around this by making it look like an “A” or “AAAA” record.


I don’t have Chrome, but I have Brave (built on Chrome) and Firefox.

Open Chrome’s Dev Tools (F12) and keep an eye on the Console and Network tabs. You might be getting a Mixed Content error.

This topic was automatically closed after 30 days. New replies are no longer allowed.