All of a sudden my site is redirecting to a different location

Problem description: my plain html one page site is located under google drive and routed from cloudflare. First few days were okay but now it is redirecting to wrong url location

Timestamp (UTC): UTC/GMT -5:00 hours

ZoneName/ZoneID: 35adf448b7ea7f6d2dff6bbe5652563b

Problem frequency: always

Steps to reproduce problem: (If the issue occurs behind a login page, also provide temporary test credentials) just hit the url with shown as below expected results

Actual results: [https://drv.tw/]

Expected results: [https://www.sawdaintelligence.com]

Additional info: from my google drive host service i can browse the url as i expected

It seems to work with the Apex but not with www.

Check your Page Rules for any redirects

curl -I www.sawdaintelligence.com                      HTTP/1.1 302 Found
Date: Tue, 28 Jul 2020 18:39:48 GMT
Content-Type: text/html
Connection: keep-alive
Set-Cookie: __cfduid=d3be6697d758eb583097d8036000459961595961588; expires=Thu, 27-Aug-20 18:39:48 GMT; path=/; domain=.sawdaintelligence.com; HttpOnly; SameSite=Lax
Location: https://drv.tw/
X-Cache: MISS
Set-Cookie: uid=rBEO6V8gcPRu8CgtwQ/RAg==; domain=.drv.tw; path=/
CF-Cache-Status: DYNAMIC
cf-request-id: 04385251190000dc4bc2063200000001
Server: cloudflare
CF-RAY: 5ba0b994fd16dc4b-LHR

Hi Mark, I very much appreciate your kind response. I m struggling through this last couple of days. I do not have literally anything in my html. you can browse it

I didn’t find anything suspicious. Another thing is it was working all right but now i can’t locate . Please help me with steps to follow.

Thanks.

Honestly I have no clue how this drv.tw thing works and how should be set up. Can you post some screenshots of your DNS settings and Page Rules? This might shed some light here.

They provide you with a random link, followed by your domain name, right? Using these radom link without your domain results in a 404.

I tried follwing now:

https://sawdaintelligence.com throws back different errors. From 520 (unknown) to 525 (SSL handshake failure)

https://www.sawdaintelligence.com is being redirected wit HTTP 302 directly to drv.tw instead of your GDrive folder.

1 Like

Hi Mark, Thanks much for your kind help. However, I solved it as i had to add another CNAME with DRVW.

Thank you very much and i m happy :slight_smile:

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.