All my subdomains are redirecting to https when I proxy them in Cloudflare and I don't know why. Yes, the "Always Use HTTPS" setting is disabled :)

(Sorry this post includes obfuscated URLs, because when I use real URLs the spam filter eats it!)

baseballseasons dot zengm dot com - redirects to https version, which doesn’t exist, so there is an error page.

baseball dot zengm dot com - very similarly configured site, which was exhibiting the same problem as the previous one, until I disabled the Cloudflare proxy for that subdomain. Now the http version works.

Any idea why this is happening? I’m observing the same thing for several subdomains on this domain. They definitely used to work fine, using the Cloudflare proxy with no https redirect. It’s possible that they stopped working a few months ago, since these are legacy products they may have been broken for a while without me realizing it. But as of like 6 months ago, and for a few years before that, they were definitely working.

Here are my Edge Certificates settings, I’m not sure if anything here is relevant.

The SSL/TLS mode is currently “Full”. The redirect seems to still happen even if I change it to “Flexible” or “Full (strict)” - it just has a different error message in those cases, but the same fundamental problem (redirecting to https) happens for all of them.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.