All my sites down due to ssl version issue only with Chrome

Starting from today I Get this error This site can’t provide a secure connection

com uses an unsupported protocol.


This Happens only with Chrome and affects all my Websites.

Anyone with the same issue?

1 Like

This happens only with Chrome. All the other browsers do not present the issue at all. It is affecting all my websites. Is there a general issue with Chrome? I tried to disable enable back Universal SSL and purge everything. After a while access from Chrome was possible again and then again same issue.

This is the message I get in Chrome → Unsupported protocol
The client and server don’t support a common SSL protocol version or cipher suite.

Any chance you happen to be using ClickFunnels also? We’ve been experiencing this issue intermittently for weeks. Most of our domains having the issue are on ClickFunnels and we’re trying to determine if the two are related, or if this is just due to Cloudflare.

Hey Jamie,

Glad to hear we’re not the only one having issues, but sad to hear that even the CFProTools master is too.

I just posted about my issue in a bit more detail here: *ERR SSL VERSION OR CIPHER MISMATCH* on Multiple Domains

Waiting to get some feedback, but disabling Universal SSL in Cloudflare seems to resolve. I know its not a long term fix, but might be something to consider until we hear back on this.

I mention in my post about DigiCert Certificate deprecation which might have something to do with the problem. Not sure though…

1 Like

Thanks for the extra info. Yes, unfortunately, we’re seeing this issue as well. It’s completely intermittent for me and random on domains impacted versus not.

I’ve also thought that it might be related to the DigiCert deprecation although I don’t quite understand why. The timing just seems to be uncanny, as that process started about a month ago and I’ve been experiencing the issue for about the same amount of time.

Yes same situation here, so everything appears much more clear to me now.

I made some test and I noticed that if I simulate the problem with Windows machines (I tried with 2 running win 11) the issue occurs.

However if I use Linux devices with exact same Chrome profile everything works fine.

I tried to deactivate all the extensions in Chrome on the windows machines, still same result.

At the moment seems to me an issue only happening with Windows.

A last note on this, I was experiencing very slow Security Check Verification when accessing any Web page for months, sometimes really extremely slow and not sure if this is related somehow to the current issue.

Anyway at the moment the relation seems to be Windows → Universal SSL → Chrome → CF

I have a ticket open with CF, they seem to be very responsive on this so let’s see.

When you say you have a ticket open with CF, do you mean Cloudflare or ClickFunnels?

Are you using ClickFunnels at all? I’m trying to determine whether this issue just affecting ClickFunnels user domains.

I have a ticket open with Clickfunnels

It’s possible you’re hitting this ongoing incident:

I’d recommend retrying once that incident has been resolved.


We are having the same issue ERR_SSL_VERSION_OR_CIPHER_MISMATCH on Chrome. We DON’T use ClickFunnels.
Based on debugging so far, our sites are working as expected for Chrome on “116." versions but the recent updates from Chrome, version "117.” are breaking.

Thank you! this is very useful

thanks, can you confirm if you are testing with Windows or with another OS?

and you were totally right, issue has been marked as resolved and all is working again

We were testing it with macOS

Ok thanks, interestingly with Linux instead there was no issue at all. Glad this has been fixed.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.