All my domains (wildcard) incorrectly flagged as phishing, Review buttons not working

Hello,

a few days ago i realized that my domains get the known “phishing” warning when entering.
Most sites are exposed via CF Tunnels and are only accessible after authentication.I can also guarantee that not a single domain hosts any malicious content or phishing.

I realized that ALL domains in my account got the same warning and were wildcard-flagges as malicious (e.g. mydomain[.]com/ ).
Even more unfortunate is that the grey Review-Button that is shown next to the warnings is not working or doing anything when clicked (tried chrome/firefox/edge on linux/windows/andoid, so i´d exclude a client side issue). That way i cannot even properly enter an objection.

I also read on similar issued online that i should have gotten an email with an explanation on what has happened and why ALL domains are flagged as “phishing” (despite not even hosting anything), but nothing arrived. (also checked junk folders and such.) Notifications on domain renewals and payments yesterday however worked.

I created a general purpose ticket that was answered quickly but closed with the information that the Trust & Safety team will handle this, but without the possibility to properly object, i assume they will not do anything, leaving all my domains flagged (killing also my APIs)

i checked also upstream providers for domain reputation (google safebrowse, netcraft, …) - all negative without any findings.

some sample domains are:

  • balloon99[.]com
  • secudillo[.]com
    but all others are also wildcard-blocked.

How am i supposed to get this issue resolved if i cannot properly object or at least find out what is going wrong here?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.