AirPort Time Capsule and Comcast


#1

I have Comcast as well (Minnesota, USA). I also use my own modem, and a couple of AirPort Time Capsules. I tried to change the DNS server addresses on the one connected to the modem, and when it tried rebooting, I just got an amber light on the front. When I disconnected it from power, and restarted it, it booted back up with the DNS server addresses that were on it previously.

How would I go about changing the DNS Servers for them? AirPort Utility? I know Comcast was blocking the 1.1.1.1 and 1.0.0.1 addressed per another thread.


#2

can you try the following commands first to see if you can hit our resolvers?

dig cnn.com @1.1.1.1
dig cnn.com @1.0.0.1

If you’re on a PC I uh can probably try to remember the nslookup equivalents. If you get a response from both with the IP address for CNN then using them both is good, otherwise you probably just want to use the one that works (assuming one works).


#3

For Windows you can do it easily in interactive mode:

  1. Type nslookup in the Command Prompt
  2. You are in interactive mode, type server 1.1.1.1
  3. Do the lookup you want, here cnn.com
  4. Repeat 2-3 for other IP

Higher latency ping from New York City!
#4

Thanks @matteo I used a Windows machine for 20+ years, switched to a Mac 18 months ago and forgot even the simplest things. :frowning:


#5

I’ll try those when I get home & let you know what I find. Yes, I should’ve mentioned I’m on a Mac. I haven’t used a PC regularly for the past 5 years. Thanks!


#6

Don’t get me started on Windows, switched to Mac in 2008 (realized now it’s 10 years exactly :v:), never looked back! Have Windows in a VM just for the sake of it (and free license from the Uni, that Uni that we know :joy:), but I turn it one just for the updates.


#7

Sorry it’s taken me a while to respond. Here’s what I’m getting from the Terminal commands:

Last login: Sun Apr 8 13:09:18 on console
LarsensRetinaMacBookPro:~ nllarsen$ dig cnn.com @1.1.1.1

; <<>> DiG 9.10.6 <<>> cnn.com @1.1.1.1
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 63159
;; flags: qr rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1536
;; QUESTION SECTION:
;cnn.com. IN A

;; ANSWER SECTION:
cnn.com. 1 IN A 151.101.1.67
cnn.com. 1 IN A 151.101.65.67
cnn.com. 1 IN A 151.101.129.67
cnn.com. 1 IN A 151.101.193.67

;; Query time: 13 msec
;; SERVER: 1.1.1.1#53(1.1.1.1)
;; WHEN: Sun Apr 08 13:11:59 CDT 2018
;; MSG SIZE rcvd: 100

LarsensRetinaMacBookPro:~ nllarsen$ dig cnn.com @1.0.0.1

; <<>> DiG 9.10.6 <<>> cnn.com @1.0.0.1
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 8653
;; flags: qr rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1536
;; QUESTION SECTION:
;cnn.com. IN A

;; ANSWER SECTION:
cnn.com. 60 IN A 151.101.1.67
cnn.com. 60 IN A 151.101.65.67
cnn.com. 60 IN A 151.101.129.67
cnn.com. 60 IN A 151.101.193.67

;; Query time: 14 msec
;; SERVER: 1.0.0.1#53(1.0.0.1)
;; WHEN: Sun Apr 08 13:12:11 CDT 2018
;; MSG SIZE rcvd: 100

LarsensRetinaMacBookPro:~ nllarsen$


#8

Since both of those replies look successful I think you should be able to change to Cloudflare’s DNS servers either on your Mac or the airport device. Doesn’t appear Comcast is blocking those for you.


#9

I’ll be sure to try that again soon. The issue I ran into last time is when I went to change the DNS Server in Airport Utility, the Time Capsule restarted, and then never came back online (the amber light persisted instead of the green light), so I had to power cycle it, and then it came back green, but it had reverted back to the original Comcast settings.

I have a bit of a unique set up, which might effect it. I bought my own modem that connects to the cable from the wall. I have a 2TB Time Capsule connected directly to the modem in the living room, which serves as the main router to which I have several devices connected (a Lutron Hub for it’s HomeKit enabled Caseta lights, as well as an Xfinity Home router the touchscreen portal connects to for our home security). I then have an older 2 TB Time Capsule, in the bedroom, and an AirPort Express, in the office, both connected wirelessly to the main Time Capsule in the living room, set to extend the wireless network.

I thought it’d be easier to change the DNS Server on the primary Time Capsule, and those changes would be pushed out to the other devices, but maybe it’d be easier to just change them on the device I primarily use to connect to the internet, i.e. Mac, iPhone, iPad, etc.

Thanks again!


#10

Update: I was able to successfully update the DNS Settings in Airport Utility for all of the routers on my network! I hadn’t had a chance to do it until now, but everything went super smooth. I also, just for redundancy, went in and changed the DNS Settings on my iPhone & Mac that connect to the network.

I’ll let you know if I have any issues and how performance has been.

Thanks!