.ai domain from namecheap is unreachable

I’ve transferred the nameservers for www.loudandclear.ai over from Namecheap to CF and the transfer seems to have worked fine, but I can’t get the page to open, neither the root nor the www.

So I went down the rabbit hole and found ideas that it might have to do with the DNSSEC. I then found this loudandclear.ai | DNSViz which doesn’t look right, but I don’t know enough about DNS to fix it or even understand it.

I tried setting up DNSSEC on both CF and Namecheap, and deactivated it again, but I see no improvement. Can anyone please point me in the right direction?

I just found out the .AI TLD does not support the DNSSEC option, so this can’t be it. I have no idea why my page isn’t displaying…

Greetings,

Thank you for asking.

If you recently changed your domain nameservers, usually the DNS propagation process could take up to 24 hours, but sometimes it takes a bit longer like 48 or 72 hours to fully propagate due to the DNS cache at our local ISP providers.

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

I see this when I access your Website - May I ask if this is expected or?
Can you confirm it is working? :thinking:

Furthermore, I can see your domain name is using Cloudflare nameservers:

;QUESTION
loudandclear.ai. IN NS
;ANSWER
loudandclear.ai. 21600 IN NS dante.ns.cloudflare.com.
loudandclear.ai. 21600 IN NS luciana.ns.cloudflare.com.

True, thank you for feedback.
I do see .ai TLD doesn’t support DNSSEC too.
But, I also see DNSKEY 2371 which is pre-added from Cloudflare? :thinking:

So, DNSSEC is disabled at the DNS tab of Cloudflare dashboard for your domain name?

Kindly, I’d suggest you to write a ticket to Cloudflare support due to your account and/or domain issue and share the ticket number here with us so we could escalate this issue:

  • Login to Cloudflare and then contact Cloudflare Support by clicking on the Get More Help button. If you get automatic reply, reply and indicate to it you need more help and reference to this topic
  • Or send an an e-mail to support[at]cloudflare[dot]com from your e-mail associated with your Cloudflare account

Hello fritex,

Thanks for the reply.

A little additional info, since this seems to have done it: I am hosting my app on Heroku and I set the target on CF based on what Heroku was asking for.

The page you are seeing now is indeed intended and it’s working now, but to achieve this I had to use the “.herokuapp.com” target on CF instead of heroku’s actual generated/suggested targets. I’m not sure if this is going to cause any issues in the future, however it didn’t work any other way and this seems good enough for now.

DNSSEC is now deactivated on both namecheap and CF. I suppose they DNSKEY was pre-added to CF previously when it was active?

Anyway, unless you know a way to use Heroku’s targets, I am happy with the current state of the configuration so we can close this.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.