AHH! has_redirect_loop ERROR your request resulted in a redirect loop

PROBLEM: has_redirect_loop

Yes, your request resulted in a redirect loop.

Setting up this domain between cloudflare and bluehost so I can use clickmagick. We have been working at trying figure out this ssl problem for days. Bluehost does not seem to know they keep working at it and cannot find a solution. Seems like a simple one. Other people in my class have it working but they are mainly using host gator. The error is so inspecific, where do you look to find it. We turned off all ssl apps in bluehost/wordpress but it does not seem to help. Without cloudflare eveything seems to display. But when I install cloudflare there is a disconnect and they cannot ssl together. Seems like a simple thing, but it seems hard to find. Any help or direction would be appreciated. Have uninstalled and installed cloudflare like 20 times. Nothing seems to work. Ideas?

Make sure your domain has SSL configured at your host and that your site is configured for HTTPS. After that, make sure SSL/TLS at Cloudflare is set to Full(Strict).

If you post your domain name, we can take a closer look.

I have made an effort to make sure domain has SSL (Now Activated plugin also in wordpress - Really Simple SSL) Have HTTPS configured in my site. SSL/TLS at cloudflare is set to Full (Strict). Did not seem to make a difference, same result.)

Domain is: https://www.fulleduc.com

Thanks for any help you have.

Eric

The good news is that it does not appear to be an SSL issue. The first redirect goes to HTTPS.

After that, the redirect bounces back and forth between www and non-www. WordPress says your site doesn’t use the ‘www’ prefix. Something else is saying it does.

Do you have any Page Rules here? Or a .htaccess file with a rewrite statement? Or maybe a setting at your host for www vs non-www.

Yes, got it working. I talked to blue host and gave them what you said. They told me to change the Cloudflare settings encryption to FLEXIBLE and it is now working. Strange, but it works. Thank for your input, it made it possible to figure out the next step. Have an Incredible Day!

They essentially told you to disable encryption. I would change host based on that “recommendation”.

Change it back to “Full strict” and tell them to fix your server configuration.

1 Like

Did not know this. Thanks I will keep at it and figure out how to get it running and fix server configuration. Talk to you soon

This topic was automatically closed after 30 days. New replies are no longer allowed.