After some times .js files not loading, 2 month i look on this and its still not fixed

2-3 months ago I had problems accessing the site

some js files cannot be downloaded

I tried different options for caching modes and did not find a stable result

if I activate development mode on the site, all files load normally, if I turn off the development mode, I can’t upload any js files.
I was not had problems with catching files from cloudflare , but 3 months ago it began to be problems that can not give consumers opportunity to use the services,
I always change something in the settings for the catch, and this does not help much.
how it works, I am not andesnted, because it does not really work, how it should

3 months I can’t stabilize the domain, every 3 weeks there are times when many other domains cannot be accessed until I turn on development mode on all domains

I’m tired of this, it takes too much time, please help

A 522 is covered at Community Tip - Fixing Error 522: Connection timed out

The error message is actually pretty clear. Your server does not respond in time to Cloudflare. You should either talk to your host about that or hire a consultant who can fix your server configuration.

can you please tell me why if i activate development mode everything working fime imidiatly, and when i disable development mode i got absolutely tha same problem

How is this interconnected at all *? and how is it possible to influence this other than buy another domain? because on any other domain don’t have such problems

i compare all settings with any others domains its realy give me mad i not andestend why its happens

Development mode only changes how caching is done. If anything, you should experience this only when development mode is on, as there is nothing cached in that case and it always goes to your server and that very connection appears to be the issue according to your screenshot.

Right now I cannot reproduce your issue, but again a 522 indicates an issue with your server. It might be best to collect the connection IDs of those failed connections and open a support ticket. They might be able to tell more on why the connection timed out.

I only know one thing
as soon as I turn on development mode everything works fine

That doesnt help much in this context I am afraid.

i dont know what is level you have but you can easy reproduce this

this link i create with api cloudflare for activate and diactivate development mode

you can try any time how its working

No query string - this way not stable

Ignore query string - this way stable then rest , sometimes 1 week not have problems, i make for this domain 20 $ mode and its help for sime time , i dont know if its interconnected, but after i do it domain was stable 2 week, and today its happen again even with Ignore query string, i jast activate and deactivate development mode and reproduce this problems again and again

Standard - allways give problems

Hmm, that appears to be a bit awkward. Can you post a screenshot of your DNS settings, redact the IP addresses if you want. Though should you feel comfortable posting your IP address here, that could help in debugging.

What does that CDN URL you just posted actually do? Just toggle development mode?

this url just Just toggle development mode

i try make one changes, now all js and css loading each time like new file . but its still not hepling even with this way this file not loading sometimes , usually not loading when disable development mode

Is your server configured to only accept Cloudflare connections?

no, server working without even firawall

In that case it is a bit mysterious, as Cloudflare does return content, however your server does not respond at all. I cannot explain why Cloudflare would return anything at all, but if you say you have no network restrictions on your server, it definitely should return something and you want to fix that first.

AGAIN THA SAME PROBLEM , js and css files not loading as well you can se it if you just reloading page , i have more that 10 services that have this problems from yesterday! and this only one of them

This topic was automatically closed after 30 days. New replies are no longer allowed.