After some advice

Hi first time poster after some advice

Getting the landing page redirects error in gtmetrix but have just read up to enter final url ie https://example.com/

Strangest one is since I added my domain to cloudflare a few days ago I cannot customize my pages in wordpress

I can login to my dashboard but if I click ‘visit site’ it takes to my domain www.example.com but the black tab is missing at the top of the page ie customize/edit page

Its almost as if I have lost admin rights to edit page but can still login to site

Any advice would be greatly appreciated

Hi @gap30,

This is probably happening due to your cache settings.

Have you set up a Page Rule with “Cache Everything”?

Hi thanks for the quick reply yes i have:

example.co.uk/*

SSL: Full, Cache Level: Cache Everything

1 Like

In this case you need to add a new rule above this Cache Everything one.


Matching:

*example.co.uk/wp-admin/*

Settings:

  • Cache-Level: Bypass

You can also take advantage of this new rule to make some fine tuning according to your needs. For example, disabling performance features and increasing security level.

example.co.uk/wp-content/uploads*

Browser Cache TTL: 2 days, Cache Level: Bypass, Edge Cache TTL: 14 days

example.co.uk/wp-admin*

Browser Integrity Check: On, Security Level: High, Cache Level: Bypass, Disable Performance

example.co.uk/*

SSL: Full, Cache Level: Cache Everything

My page rules

The way the rules are set up, you should no longer experience the problem initially reported, however it’s likely possible to optimize them.

Why are you bypassing cache for your /wp-content/uploads? These files are (most of the time) purely static and do not change after they have been uploaded.

How could i optimize them?

I will remove the ‘bypass cache’ from /uploads thank you

It’s hard to say exactly how, since it depends on your needs.


As for the example.co.uk/wp-admin/* rule, I usually put it first in the list, with the following settings:

  • Always Online: Off
  • Browser Integrity Check: On
  • Cache Level: Bypass
  • Disable Apps
  • Disable Performance
  • Security Level: High

You could probably increase the example.co.uk/wp-content/uploads/* Browser Cache TTL to 8 days.


Take a look at this Page Rules Tutorial from Support Center:

I hope it helps! :slight_smile:

1 Like

I think I have worked out what the problem is - its something to do with clearing/deleting cache in wp fastest cache

I was editing my homepage earlier and after I finished I clicked on ‘clear cache’ then ‘delete cache’ then bam instantly logged me out of admin area

So same problem is back can log into dashboard but cannot edit pages

Thing is I am not technically up to speed/fully understand how ‘delete cache’ is giving me this problem I need to do some reading

I am on a lightspeed server so should be using lightspeed cache plugin but had issue uploading images

Sorry if this is off topic

This topic was automatically closed after 14 days. New replies are no longer allowed.