After setup free cloudflare for ssl and cdn email not receiving

Hi, I have setup Cloudflare for SSL & CDN my 2 domains and but after setup email are not receiving. I am trying to fix this issue from 2 days but totally. I have troubleshot and try to solve but failed. Can you please give me instructions on how to setup? It’s very important for my business. Thanks

Shahzad G.

Those are both a bit tricky because it looks like your MX record points to your root hostname (, which is set to :orange:. Cloudflare renames these to hide your origin IP address. It’s best if the mail server isn’t on your web server for this reason. Here’s some more information:
Troubleshooting Email Delivery Issues when using Cloudflare

@sdayman. I really appreciated your quick response and I have read the article but sorry to say that I still not understand what I have to do? Can you please advise me specifically for my domains. If you need more information I can share it with you. Thanks

This looks like a problem with your email server. I’ve tried a few different tools and they all fail with similar messages:

MX Record Target: 0
IP address: []
Status: Connect failed
Test duration(ms): Timed out...

It looks OK if I connect manually with telnet. Google seems to indicate you need to look for delay_unknown_hosts in your exim config and reduce the delay from 20 seconds to something more reasonable, like 5 seconds.


Should I need to talk with my hosting provider?

They should be able to help. The DNS for your email is pointing at the correct IP addresses, so I think it’s up to whoever looks after the exim configuration.

I have contacted with my hosting provider and they said “Kindly switch off orange cloud in Cloudflare settings in front of MX record and then try again”

But In front of the MX record, there is no cloud icon. The icon is only in front of the A & CNAME record. can you please circle on it which exactly I need to switch off an orange to grey. Thank you so much.

Cloudflare has magically made your MX not-orange cloud, but you can simplify this by doing the following:

Delete the CNAME called mail, and create an A record called mail, with the content set to Make sure it is :grey:. Delete one of the MX records, the one pointing at Once this is done, wait 5 minutes, and try your email again. I’m pretty sure it will still fail, and your hosting provider needs to do some work.

Also, you have a record for ftp that is :orange:. If you use this for ftp, then it needs to be :grey: also or ftp will not work.

1 Like

My hosting provider tell me to make grey icon in front of following entries:
CNAME - Mail
A - Webmail

after going that receiving emails but still is not working. i did same with but still not receiving.

I did same as hosting provider said for but its not working.

You’re still using a CNAME for ‘mail’. Please double-check @michael’s instructions.

Webmail should be :orange:, as that’s an HTTP connection.

I did id as michael said also not working.

Those records look good. And I only see minor warnings about your server.

What happens when someone tries to send you email? Does it get returned?

Are you able to send email out?

its working now. thank you so much for your kind support. but i am facing another issue. as i said: i am using sub-directories

All sub-directories are working but /in is now down from 3,4 hours. It was working very fine. I didn’t did anything buts now its not working. Showing following error, please check attachment.

It’s redirecting back and forth between http and https.

Ok thank you so much. I have just created new database and restore backup. thats it.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.