After setting up cloudflare on my private domain I stopped receiving emails

Our small website is hosted at namecheap. They do not provide a free SSL or even allow integration with Let’s Encrypt. So our website was showing “Not secure” in Google Chrome. Someone recommend signing up a CloudFlare account and enabling their SSL. Which I did about 6 hours ago.

Everything seems to work well with the website, except that I cannot receive any emails. Our email address is [email protected]_domain.com and Outlooks just shows no messages even if I sent a bunch of test emails to that address.

Here’s the settings in that email account:

CaptureEmail

As you can see it’s using the Namecheap’s server, which is serverNNN.web-hosting.com to receive incoming emails.

What can I do to fix this?

Have a look at this one

1 Like

Thanks for the info. It turns out that the automatic conversion script at CloudFlare picked up all DNS settings correctly. I had to contact namecheap tech support to get their help. This is what was causing the issue (quoted, according to them):

03:37: I have changed the host to "serverNNN.web-hosting.com " in the “Destination” menu in SpaxExperts interface.
03:38: The matter is related to the fact that “host” field in the “Destination” menu in SpaxExperts interface contained “mail.private_domain.com” value.
03:38: mail.private_domain.com is proxied by Cloudflare, thus it is hidden globally.

I’m not very sure what all this means, but the tech support person had to do it on their end (for me) to make it work. I’m posting it here in case someone else runs into the same issue.

This topic was automatically closed after 14 days. New replies are no longer allowed.