After setting up cloudflare my dynamic content and login does not work


#1

https://www.journalines.com/

Tried Firefox and Chrome

I set up cloudflare for my website and I noticed that the dynamic content is not loading on the home page.

The login box comes up but after entering the login info the button is unresponsive.

I have tried turning off the cache but it does not seem to change anything.

Does anyone have any suggestions?

Thanks.


#2

If you look in the developer tools the issue is that the requests are to HTTP endpoints (which is really bad, especially for passwords!). Change those to HTTPS and it should work fine.

I would make sure, especially since you are handling passwords, to have a valid certificate at the origin setting the SSL Crypto setting in the Cloudflare dashboard to Full (Strict).


#3

This may be a stupid question but where do i find developer tools section?


#4

Well it depends on the browser. Google “developer tools” + name of the browser.


#5

If this is specific to the browser and I make a change in google developer tools, anybody else that wants to log in will still not be able to login from their end.

I figured this would be changed in hosting or with cloudflare.


#6

It is changed in hosting (there is an option to do it Cloudflare’s side, but it’s cumbersome, unnecessary and mostly just not recommended if it’s possible to avoid), the developer’s tools are accessed in different ways depending on browser (and often even OS) and show issues (and a ton of other things). You can’t change anything website related from there.


#7

Should the change be made to the htaccess file? I am not seeing anything in the godaddy hosting account where the change could be made.

Thanks.


#8

It’s in the actual HTML/JS code. It’s not a toggle.


closed #9

This topic was automatically closed after 30 days. New replies are no longer allowed.