After purging the cache my page was affected

ok thanks for being attentive that you advise me to uninstall it or how I can correct this error, sorry I’m not an expert web developer.

It looks like it’s showing 524 errors.

1 Like

Correct. 524 are timeouts, but you on top of this also do have normal 500 errors (internal server error) and even some 404 errors (not found):
524 & 500

404

Please reqzest these URLs directly from your server and see what it results in and in general please check the logs on your server.

2 Likes

ok, thanks for answering and being attentive! I have a backup before purging, I will contact my hosting to see what we can resolve, in any case do you think it is prudent to restore the site and remove the clouflare dns?

I would not recommend removing Cloudflare’s DNS.
What I would do is: buy and implement APO and instead let go of Autoptimize and any other caching Plugin.

That should guarantee a good integration into Cloudflare and top performance worldwide.

ok if I implement an apo plugin can I solve these inconveniences? then it suggests me to eliminate autooptimize and wp fast cache, another question as I have these problems I was thinking of leaving the account in developer mode so that only the images of my server are shown until I can solve this, would that be ok?

Yes, that is what I would do. These Caching tools are ok, but apparently it seems that there are some incompatibilities with Cloudflare, so removing them completely and instead switching to APO would be a good try.

I guess it will be ok. But please try this first:

  • deactivate and remove just “wp fast cache” (leave “Autooptimize” active) and then try again.

If it then works “wp fast cache” is the problem. Replace it with APO. If everything works without “wp fast cache” you don’t need to activate developer mode.

ok friend, in a couple of hours I’ll get home and get on with it! I will be communicating the result here, thank you very much, Martin.

Hi martin , back here again ! already deactivate the plugin that you told me and did not work in fact delete the wp fast cache then I did the deactivation of all plugin and activate them one by one and the web remains the same , what makes me curious is that when I enter the wordpress desktop and put the domain is another tab but in development mode looks good and no problems.

I should have mentioned, that you also need to wipe all possible caches (also Cloudflare caches - Purge Everything) and regenerate the files generated by autooptimize.

Now I just see 404 errors, no 524 and no 500 errors anymore.

Okey I already entered the windows system console and delete the dns cache, I would appreciate if you can explain the steps because yesterday I just did it, I deleted the cache that I just mentioned and the browsers, but the error remained, can you tell me the steps if I have to do to see if I do not know any, thanks!

Since you deleted wp fast cache and it did not solve the issue please do this:

  1. log into your Wordpress site as admin and also remove the plugin “autooptimize”
  2. clear/purge all caches at Wordpress.
  3. go to: https://dash.cloudflare.com/?to=/:account/:zone/caching/configuration and execute “Purge Everything”

That’s it for now. Once you’re done, tell us here. I will then again check your website.

I’ll let you know, I’ll also mention that I have a child theme so that there are no changes in customization when updating, I do not know if it is the theme that is causing problems.

Hello martin good morning, I answer you now because the Cloudflare system told me to wait 19 hours to send another message because I had exhausted my daily quota, yesterday I did the first step delete the plugin autoptimize , Second enter the cpanel control and in the wp-content folder locate the cache folder and delete all content inside and finally purge all the cache in Cloudflare , I followed all the steps you indicated me , I still see the same web but there are users who say that everything looks good and others do not .

I have also noticed that in development mode when I enter wordpress in incognito mode the page looks good in another tab and when entering mobile also, when I see it in desktop mode in another browser outside login is that you see the errors.

Actually I still see assets beeing served with “autoptimize” in the URL, so the plugin is still active.

Good morning Martin, sorry but the plugin removes it completely, in this case if there are traces how would I remove them?

That is not related to Cloudflare, since Cloudflare does not cache the HTML atm. But I found something else.

There is a header set: x-nginx-upstream-cache-status: HIT
So somewhere between Cloudflare and your Wordpress application there is an additional Nginx Cache. Please find him and disable him. Do you run on cPanel by any chance?

ok , if i have how to enter cpanel , how would i delete it ? Or what would be the steps?

I am sorry this is beyond the scope of this forum, also I do not use cPanel frequently. Just do your research on how to disable nginx-upstream-cache for your panel and disable it.

After you have done this tell us, so we have a look at it again.

Ok, I’ll investigate it and report here again! Thank you