After move to CloudFlare MX record not routing

Hi Team,

After transferring my domain, I moved my ns from GoDaddy to Cloudflare. Email is not working as I have checked the DNS check MX record is not found.
But I have added it manually and checked but still not working. Please help me resolve this issue.

Welcome to the Cloudflare Community. :logodrop:

Can you share your domain name so that Community members can examine your DNS?

If you get a warning about including links in your post, you can use </> Preformatted text to render the domain as plain text.

Hi .
Thanks for your time and support. I was able to fix the issue by adding the correct MX record and it was working fine. However, I’ve noticed that I cannot proxy the email record on Cloudflare. If I enable the proxy, I’m unable to send or receive email.

Is this expected behavior? Is there any way to proxy my email record on Cloudflare while still ensuring that my email works properly?

domain name:

You cannot proxy a mail server through Cloudflare. An MX record must point to an unproxied host.


Thank you for letting me know. So I cannot use Cloudflare SSL for my Email server? Is there any way to ensure secure connections to my email server while still using Cloudflare for my domain’s other services?

Thank you for your help!

That is correct, you can’t use Cloudflare SSL for a mail server.

Certainly. You only need to obtain a valid certificate and configure your SMTP server to use it. The specifics are out of scope for discussion here. The best place to start may be forums for the control panel or operating system you are using.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.