After enable "Always Use HTTPS" and "Automatic HTTPS Rewrites" showing error

ssl certificate setting

Describe the issue you are having:

We are using godaddy’s domain where ssl certificate is also provided but when we use default setting given in Cloudflare which is “automatic redirect” and “always use https”, it creates many redirects tells. Please tell me (we using fullEncrypts end-to-end, using a self signed certificate on the server” and under the " Edge Certificates (Always Use HTTPS “off”) and (Automatic HTTPS Rewrites “off”) it is correct or we need to make some changes in it.
after enable “Always Use HTTPS” and “Automatic HTTPS Rewrites” showing many redirect in some place.

if you want screenshot please make email

This tells me you returning a redirect from the origin which conflicts with Cloudflare’s.

Given you have a Full SSL setup (I’d recommend putting a valid certificate on the origin and switching to the Full (Strict)) you are probably returning an https to http redirect from the origin, without a domain name nor a screenshot I can’t confirm, though.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.