After cloudflare account info migration to another email - Company Emails not working now - Urgent need support please

Dear,

Please can someone please support our issue its very urgent please.

We cannot receive any emails to our company emails.

Our domain: origin-technology.com
Our new cloudflare login: [email protected]

Recently we moved our cloudflare account info to another account and people are receiving error below when they try to send emails to us.

Message not delivered

Your message couldn’t be delivered to ****@origin-technology.com because the remote server is misconfigured. See technical details below for more information.
The response from the remote server was:

554 5.7.1 <********@origin-technology.com>: Relay access denied

Check if those ppe-hosted.com hosts are the right addresses for your emails, but if they are that message is coming straight from them and you need to clarify this with your mail host. Cloudflare is not involved here.

If they are not correct, then you need to fix that but that’s also something you need to clarify with your mail host.

What is Cloudflare related is that - assuming your server IP address ends in 163 - you have a broken certificate on your server and an insecure encryption mode on Cloudflare. In short, your site is still insecure.

The following article has every detail on what you need to do.

Okay thank. Yes issue is solved now.

Issue us goddady didnt tell us we needed to update more settings for DNS after we updated our email security this occured.

Now its solved. Thank you for replying and for you support. Best Regards

Did you also fix your certificate issue and changed the encryption mode?

Regarding the certificate issue.

I contaced our hosting website they did not understand what the issue is.
As per godday and our hosting they said our website is secure we also have security headers added.

I dont know how to solve this issue below u mention:
assuming your server IP address ends in 163 - you have a broken certificate on your server and an insecure encryption mode on Cloudflare. In short, your site is still insecure

What’s your encryption mode on Cloudflare?

I dont know how to find that info from cloudflare.

Post a screenshot of https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls.

Okay just found it now.

Our encryption mode is full.

That’s precisely what I referred to. You have an insecure mode here.

  • Change that to Full Strict
  • Pause Cloudflare (Overview screen, bottom right)
  • Make sure your site loads fine on HTTPS without errors
  • And only once that works unpause Cloudflare

Okay done now. I put full strict. And I tested it. Its working fine.

So now we are secure?

Thank you.

If you are on Full Strict you should be good.

Just to double check, what’s the last number (x.x.x.Y) of your IP address under https://dash.cloudflare.com/?to=/:account/:zone/dns?

Hi,

It looks like you have two different email providers configured for your domain

You also have multiple SPF records configured

Take a look at Hardenize Report: origin-technology.com for more details

Hello,

Thank you for your reply and support.

Yes we had email advanced security called proof point from godaddy before. But we removed it now. After we removed it the emails stopped working, then godaddy told us to update the records.

But the new records did not include these. So not sure if its okay to remove it? Im worried that emails would stop working again or something like that.

Best Regards

My question from before.

And you do have two different services configured now.

Hi,

In the DNS list. Under A proxied entries and DNS list… I didnt find any address that ends in 163.

You mean the ppe host as a different service? I will ask my mail provider if I can remove it.

Thank you for your support

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.