After adding cloudflare smtp not working on my site

Before adding cloudflare My smtp is working properly on my site. But after adding cloudflare it is not working. It is working on just my cpanel but inside of my website smtp not send any thing. Please solve it. Please

You can see the picture that I uploaded and marked. When I convert this setting to DNS only then my smtp works properly. But when I turn it on again that again stopped working. I think this is important to me to turned on the option. Because when I turn off this option then the ddos protection not work. I have tried others setting like mx record AAAA record to DNS only but still I have issue of smtp on my site. What can I do please.

Cloudflare will only proxy HTTP/HTTPS traffic unless you use Cloudflare Spectrum (which requires an add-on to an Enterprise plan). You will need to keep any mail-related DNS records (such as smtp) set to “DNS only”.

Ok I’m trying I will be back if it’s not work.

You can enable the proxy on your apex name if you delete the mail CNAME and replace it with an A record that has the same IP as your apex name. Make sure that new A record for mail is set to :grey: DNS Only.

Yes but kn my site it showing sent successfully. But in my another mail inbox. I’m not receiving any mail? What should I do now?

I am not sure how you came up with enable Cloudflare Email Routing from anything that was posted in this topic, but that is the completely wrong action to take. Your configuration is now a complete mess where it had previously only needed minor corrections and you have an even bigger problem than the one you had when you opened this topic.

You will need to completely disable Cloudflare Email Routing and correct your MX records and hostnames as previously described.