After adding Cloudflare free plan i got an invalid SSL error ( I have installed SSL certificate by Let's Encrypt and before it was working fine

Here I get an invalid SSL notification, what could be the possible reason?

Seems to me like you’ve encountered an 5XX error regarding the SSL :thinking:

May I ask, before moving to Cloudflare, was your Website working over HTTPS connection?
Did you had an valid SSL certificate installed at your origin host / server which covers both your naked (root) domain any any other needed sub-domain like www, mail, etc.?

If you had an SSL certificate, did you checked if it’s still valid and not the expired one? :thinking:
If it’s expired, you’d have to renew it firstly.
Therefor, upon success, make sure your SSL/TLS option at CF dashboard is set to “Full (Strict) SSL”.

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

If any other issues appear, follow the needed steps for troubleshooting from article below:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

Last but not least, kindly have a look here for more information regarding correct SSL settings at the SSL/TLS tab on Cloudflare dashboard:

Later on, now when I check, I cannot reproduce the same error you were getting.
I guess you fixed it? :thinking:
Or rather you switched your domain nameservers back to old ones at your domain registrar? :thinking:

;ANSWER 1800 IN NS 1800 IN NS

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.