After activating the Cloudflare CDN, everything has been problems

After activating the Cloudflare CDN, everything has been problems

Here again, now I have another problem with CloudFlare, maybe it is not the ideal configuration that we have but now (as you can see in the image) the Google console shows me the sites like this, previously they appeared with the icon, I do not know if Google does not is tracking or what happens, because organic searches have plummeted.

Everything happened at the root of activating “Redirected by proxy” and in Enrollment Mode “Complete”.

Someone would be so kind to help us solve the problems

That looks like four different sites. Are they all yours?

Or rather one domain, but 4 properties/entities like HTTP(s) and (non)www’s added to Google Search Console to me :thinking:

UPDATE: I’ve checked my GSC, and I can only add a note for few domains which are country restricted by custom Firewall Rules at Cloudflare dashboard.
Only visitors from one country can access it (not even Google, etc.), so I also see “no favicon” for them at the GSC interface, while I normally see the favicon when I open and browse the Website using my Web browser from my country.

  • I thought it was because of a setup where favicon and other resources (website content) are being served from a Bucket, so maybe CORS but no …

If not, you may want to copy-paste (put) your favicon (if this is the website the issue is happening?):

  • https://cultura-informatica.com/wp-content/uploads/2021/06/CI.ico

To the “public_html” folder and leave it there as GSC might (by default?) look up for it (as same as Web browser) at that location first, so if not fetched or linked to the particular one, “default favicon” is shown (I guess).

Hm, due to the redirection(s) vs indexed URLs?

1 Like

Yes, they are our sites, they appear like this as soon as we activate the Clouflare CDN

Thanks for your help. It all started when we activated the CDN, now we are not able to restore organic traffic or Google Discover. We have been like this for 2 months and we have tried everything.

Unfortunately, I have 2 websites same setup (config files, WordPress, cache, Cloudflare …), but on one I have daily Google Discover pop-ups, while on the other it’s ground zero.

Not sure why is it like that. Both have got some new blog posts each day and both are applied and confirmed to Google News (following all the guidelines) + both have got Google AMP implemented, and specific sitemap file, etc.

I think it’s about the content + visitor/user behaviour and from which source are they coming to the website (via Facebook link, Android search box → Google, or using Google News → AMP article, etc.).

May I ask if this is related to your older topic?

ISSUE one:

  1. Did you deactivated SXG and enabled AMP Real URL or not?
  1. Is Google AMP implemented on your website therefore? (YES, it is)
  2. Have you applied for Google Publisher Center (Google News)?

Nevertheless, I see indexed links are HTTPS related.

SUGGESTION one:
And you are saying you have AMP - I see, the URLs like ?amp → better to use /amp/.

ISSUE two:
I do not see a HTTP header (over your domain, neither on ?amp version URLs of articles):

  • amp-access-control-allow-source-origin https://cultura-informatica.com

You are missing this one, obviously.

SUGGESTION two:
Because of a BYPASS value and no-cache for the cache set, your webpage loads very slow to me - 6.74 seconds for PHP processing? (WordPress)

  • despite you are using APO for WordPress …

I cache even the AMP for a day, all good so far.

  • Rocket Loader option is disabled for my /amp/ URLs

Try to tune-up your PHP values a bit too:

memory_limit = 256M
max_execution_time = 300
max_input_time = 1000
max_input_vars = 5000 or 7000
post_max_size = 16M
upload_max_filesize = 16M

Also, if you can install the PHP OPcache module as it could help too :wink:

https://graspingtech.com/speed-up-wordpress-by-enabling-zend-opcache/

ISSUE three:
I see, despite APO for WordPress, you are using WP Rocket plugin for WordPress.

Search :search:

Make sure you clear your cache on WP Rocket first and then Cloudflare.

Hopefully, this is fixed WP Rocket + APO + Cloudflare and it works?:

1 Like

Hi, everything worked quite well before, the only problem was with the introduction of the Cloudflare CDN. Before we appeared a lot on Google Discover and News, we had no problem whatsoever. We enabled the CDN due to the large volume of organic search that we had. And yes, we have already disabled SXG but we do not have the actual AMP function enabled.

¡Nothing, we continue the same!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.