Adsense appear and disappear randomly in my url https://fmhit99.com/testadsense.htm

What is the name of the domain?

fmhit99.com

What is the error number?

What is the error message?

What is the issue you’re encountering

I have google adsense all configured and aproved, but with cloudflare my ads disappear and reapper, most of time disappear, the url is https://fmhit99.com/testadsense.html only there is a blank container of ad.

What steps have you taken to resolve the issue?

I review all configs in cloudflare, SSL, TLS and many more.

What are the steps to reproduce the issue?

Enter to this url, and you see and blank div with de adsense code, but no ad is show.
https://fmhit99.com/testadsense.html

I see the AdSense code is on your page. Once the code is on the page, it’s up to Google to display the ads – unless your Cloudflare WAF config is blocking AdsBot-Google.

Check your Cloudflare Security Events for the domain in question and filter for User agent contains AdsBot-Google). Do you see any instances of the Google AdSense bot being blocked?

If you see your Cloudflare WAF is blocking the Google AdSensense bot, add a WAF rule to allow the bot. See this 3d-party blog post: Google Ads “All disapproved” with Cloudflare – keithmenor.dev

If you don’t see Cloudflare WAF blocking AdSense, then I recommend asking the Google AdSense support team why they’re not displaying their contextual ads on your site: https://support.google.com/adsense/

NB: Your test page has nothing other than the AdSense code. This might just be the reason why Google’s unable to display any ads, as these ads are meant to be contextual (ie relevant to the content on the page). Also, AdSense policies specifically prohibit placing ads on “non-content-based pages” and “pages published specifically for showing ads” – both of which your blank test page is violating. But this is not the place to discuss Google AdSense policies :smiley:

1 Like